I am having a problem with the clip and the intersect tool on QGIS Valmiera. I have a large vector map of sublocations of a country and am trying to clip them to a district level since I do not need the data for the entire country. I have save both to the project CRS, and have done this multiple times. As a project CRS I am using the WRS 84/Pseudo Mercator (I am using the openlayers plugin for geographic reference). To clip I the large map goes into the Input vector area, and I have made a polygon to represent the district which i add in the "clip layer" field. Then when I clip (or use intersect), nothing ever appears. The layer is created, but is not seen anywhere on the map, and the attribute table, although the fields from the large map are present, has no values.

How can I fix this problem?

  • Welcome to GIS SE! You say "I am having the same problem" but I am unclear as to what the original problem you are referring to is. Can you edit your question to elaborate, please?
    – PolyGeo
    Jul 16, 2014 at 9:32
  • Can you add the extent of the large and the clip layer, as reported under Properties, metadata tab?
    – AndreJ
    Jul 16, 2014 at 9:34
  • Sorry I meant the same problem turns up when i use either the clip or intersect functions. The extent of the large layer is: xMin,yMin 3774797.20,-520985.98 : xMax,yMax 4663285.93,611251.45 and the extent of the small clip layer is: xMin,yMin 4183645.92,-461518.88 : xMax,yMax 4366982.29,-295984.14 Thank you in advance!
    – safisc
    Jul 16, 2014 at 10:37
  • Andre, thanks a lot!! I checked and I had an error in the geometry, fixed it and now it works. thank you again!
    – safisc
    Jul 16, 2014 at 12:17

2 Answers 2


If the extent of the clipping polygon falls savely inside the extent of the layer to be clipped (which it is in your case), an invalid geometry (such as intersecting segments) of the clipping polygon will result in an empty clipped layer.

You can test it with Vector -> Geometry Tools -> Check geometry validity or by just labelling the clipping polygon (which will return nothing too).


I had the same problem:

  1. Geoprocessing tools » Clip - gave me as result empty shapefile - reason: clipping polygon inside the layer to be clipped

  2. Using Geoprocessing tools » Intersect - brought me requested result no matter that the clipping shapefile was fully in the one to be clipped.

Intersect can be used for "cropping" shapefiles after you created shapefile of the area to be cropped to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.