You can see from the screenshots that QGIS has, in my opinion, much more pleasant on-screen rendering of vector features. I assume there is some sort of smoothing algorithm used in QGIS. Is there a way to replicate this on-screen smoothing effect in ArcGIS?

(click images for full effect)

ArcGIS for Desktop ArcMap 10.2

enter image description here

QGIS 2.2 Valmiera

enter image description here

  • 1
    @PolyGeo The screenshots are from ArcGIS for Desktop ArcMap 10.2 and QGIS 2.2 Valmiera. I updated the post to include this information. Thanks. – Aaron Jul 16 '14 at 22:59
  • 1
    Just FYI, the effect you are trying to replicate here isn't quite working because the browser is downscaling both the images because they are too wide for the Stack Exchange site layout. You have to right-click and "view image" to see them in their full resolution. I have edited your question to make the images link to themselves so that you only need to click on them to view them. – blah238 Aug 3 '14 at 18:50

The effect that you need is called Anti-Aliasing.

When ArcMap draws a diagonal Line, It will draw all pixels. This gives rise to what is colloquially called the staircase effect. When QGIS draws a diagonal lines, it makes the outer pixels of a colour with lower intensity, which gives a smoother appearance.

Unfortunately, there is no option to enable Anti-Aliasing in ArcGIS desktop. You should upvote these two idea for requesting this feature:

| improve this answer | |
  • I would be surprised if ArcGIS Pro didn't have this feature, as it's WPF-based, which does support anti-aliasing. – blah238 Aug 3 '14 at 18:53
  • @blah238: I don't have access to ArcGIS Pro. I hope someone who uses it can comment on this feature in it. – Devdatta Tengshe Aug 4 '14 at 2:57
  • 2
    Yes, Pro App has antialiasing. – Jason Scheirer Aug 4 '14 at 3:33
  • @JasonScheirer: Could you post that as an answer with supporting documentation/screenshots? – Devdatta Tengshe Aug 4 '14 at 4:01
  • @devdattatengshe The current answer is "no, desktop does not have antialiasing." A future product that is not yet shipping isn't going to help Aaron today. – Jason Scheirer Aug 4 '14 at 4:31

Best workaround I've found:

  • Export map with twice the DPI needed.
  • Open in paint and resize to 50%.

Obviously this will work best when exporting to a lossless format such as png.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.