I am trying to load a Shapefile to CouchBase (version: 2.5.0 DEV edition, installed on Ubuntu), but with no success.

According to this documentation it is possible like this:

ogr2ogr -f couchdb "couchdb:http://some_account.some_couchdb_server.com" shapefile.shp

so I tried like this:

ogr2ogr -f couchdb "couchdb:http://localhost:8092" shapefile.shp


ogr2ogr -f couchdb "couchdb:http://localhost:8092/osm" shapefile.shp

(where osm is an existing databucket) and also with permissions:

ogr2ogr -lco UPDATE_PERMISSIONS=ALL -f couchdb > couchdb:http://localhost:8092 shapefile.shp

then I tried simply to connect:

ogrinfo -ro "couchdb:http://localhost:8092"

which gives me the error:

FAILURE: Unable to open datasource 'couchdb:http://localhost:8092' with the following drivers. [list of drivers including couchdb]

I also tried instead of localhost and also with port 8091 (and every combination of these).

Can anyone verify that the couchdb ogr2ogr driver is working and, if yes, what am I doing wrong?

Maybe the problem is that it is CouchBase instead of CouchDB.

My GDAL version is 2.0.0dev

1 Answer 1


Couchbase is not Apache CouchDB compatible, hence the OGR driver doesn't work. AFAIK there's currently no OGR driver for Couchbase.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.