I am using QGIS on two Win7, 64 bit machines for years. After upgrading to QGIS 2.4 it crashes on both machines at every shutdown with the message "Minidump...". The crashes occur independant of what I have done before or whatever project I am working on. Until now there seems to be no loss of data, but it is annoying. (I do not have installed the LecoS-plugin on either machine.)

Any ideas, solutions or similar problems?

  • Can you try a 32bit version of QGIS? – AndreJ Jul 18 '14 at 8:10
  • 1
    same here but if open a existing project it does not crash - it is a bug on the 64 bit version. hub.qgis.org/issues/10756 remove plugins and restart QGIS – Mapperz Jul 18 '14 at 14:42
  • @Mapperz I think your comment should be an answer. – underdark Jul 18 '14 at 17:56

06/30/2014 Minidump on closing QGIS 2.4 there was a bug reported on the 64bit version of QGIS 2.4 on Windows 7 PCs

minidump is created on exiting (have recreated this issue)

enter image description here

Bug tracking for QGIS 2.4


Related: Plugin causing QGIS 2.4 to crash


work-around is to uninstall the plugins and restart qgis.

  • It does seem from these links that the programmers think the problem is limited to the LecoS plugin and they've closed things. I didn't have it but I had the minidumps. I solved things by renaming the plugins folders (in .qgis and .qgis2) restarting QGIS and then reactivating plugins still there and installing those that weren't. If that hadn't worked I was going to also delete the registry key HKEY_CURRENT_USER\Software\QuantumGIS. – johns Jul 18 '14 at 20:37
  • I uninstalled each plugin that can be uninstalled, restarted QGIS and reinstalled the plugins I need. After this the shutdown is not producing "Minidumps" any more. It seems to be a problem with the automatic migration of certain plugins from QGIS 2.2 to 2.4. Thanks for answer and comments. – Ulli Jul 19 '14 at 13:37

The same issue occured to all versions from 2.2 to 2.6 (Win 7 64Bit). The plugin LecoS was not installed, unlike the others. I solved the problem by removing of "GarminCustomMap" plugin (Vers. 1.0).


I tried everythings but it didnt solved until the deleted nircmd.exe and install again. The problem is solved. Also if you uninstall the qgis and again install you should delete everything after the unınstall (using the regetid; How to completely uninstall and remove QGIS 2.8.1?)

İf you deleted nircmd.exe, open the qgis. The software will ask you to install again the nircmd, you shoud say yes then problem will be solved.


Just had the same issue.

I removed the GarminCustomMap plugin, and also qgis2compat. Solved my crashing on exiting the Qgis.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.