I have a dataset in the form of a personal geodatabase (mdb) and am interested in using certain feature classes for further processing.

My problem is - I am using USGS data orthoimagery which comes in UTM coordinate system and am unable to reproject my geodatabase feature class (layer) to UTM. The same task is easily done in ArcGIS, but I want to use QGIS as there are other features of QGIS that I intend to use later on.

What I have tried: 1) Save geodatabase layer (feature class) as shp and try to reproject that shp --> the reproject task does not proceed beyond 2% completion and I end up with a 1KB shp file

2) Reproject mdb layer (Feature class) directly to UTM --> It does not allow me to do this either.

3) Create shapefile from mdb layer (feature class). Define projection for the shp file. Reproject this shp file. --> this also results similar to (1)

So, for some reason, projecting layers that have their origin from an ESRI mdb do not seem to be reprojected in QGIS.

Any help/tips on this would be welcome.

Thanks in advance.

enter image description here

  • What projection is your existing data (personal geodatabase) in? – Mapperz Jun 9 '11 at 1:08
  • the resulting shapefiles do have the .prj file? – Giovanni Manghi Jun 9 '11 at 8:04
  • @Mapperz When I create shapefile from geodatabase layer, I get a prj along with shp. I use the Save As option on the geodatabase layer and use Original CRS option Alternately, if I try to specify a new CRS at the time of creating the shp using the above method, I get the following error: Attached screenshot of error in my original post. (I tried to use NAD83/UTM 17N as my new CRS). Thanks. – nerazzurri_4 Jun 9 '11 at 23:57
  • @Giovanni The original geodatabase is in NAD_1983_Michigan_GeoRef_Feet_US I got this from ArcMap. When I tried to check the properties of the layer in QGIS, this is what I got: Layer Spatial Reference System: +proj=longlat +ellps=WGS84 +towgs84=0,0,0,0,0,0,0 +no_defs – nerazzurri_4 Jun 10 '11 at 0:05
  • P.S. I'm sorry, I think I interchanged the comments and your names. – nerazzurri_4 Jun 10 '11 at 0:06

This is a problem I have seen many times with shapefiles coming off arc*: they are missing the .prj file. If this file is missing, then the GIS Desktop programs cannot determine the vecto projection. In QGIS if you don't change the behaviour in "options -> CRS", the program will give the wgs84 CRS to everything is loaded and that is missing an explicit CRS. If this happens you then have to manually give the layer its own CRS, or as I said, change how QGIS behave in this situations. To correct the problem at the source you can for example re-save the vector ("save as...") and choosing the right CRS or you can use the tool "define vector projection" in the vector menu. For rasters you can do the same with different tools in the "raster" menu.

  • I haven't yet found a solution but I did some more testing and I found out a few things I dint know earlier: When I looked at the Metadata for the shapefiles generated from QGIS and Arc*, this is what I found- Filename: Pri_UG_Electric_Line_Segment_UTM17N_ArcVersion Projected coordinate system name: NAD_1983_UTM_Zone_17N Geographic coordinate system name: GCS_North_American_1983 .....continued in next comment – nerazzurri_4 Jun 10 '11 at 22:32
  • Filename: Pri_UG_Electric_Line_Segment_QGIS Projected coordinate system name: UTM Zone 17, Northern Hemisphere Geographic coordinate system name: NAD83 I do not know if both the Geog coord syst are same? So it got me thinking if it could be the case that QGIS and Arc* specify projections differently and thus even though two vector layers are in the same ProjCorrdSyst, they do not overlap when they are supposed to. Moreover, the tiff image from USGS could well be projected using the Arc* 'parameters' and thus the vector layer projected from Arc coincides with that tiff image. Any thoughts?? – nerazzurri_4 Jun 10 '11 at 22:36
  • I would love to have a look to your data and try myself what is going on. If you can, send me the links where to download the (original) data or subsets of them (I don't have any Arc* software, so please put them in a standard format). E-Mail: giovanni DOT manghi AT faunalia DOT pt – Giovanni Manghi Jun 11 '11 at 10:02

You could reproject the PGDB feature class(es) to shapefile(s) or any other write supported format using OGR (ORG doesn't support writing to PGDB).

ogr2ogr -f "ESRI Shapefile" output_shapefiles input.mdb -s_srs EPSG:XXX -t_srs EPSG:YYY

XXX = source SRS

YYY = SRS for reprojected output

Be careful with PGDBs outside of ESRI products as you will find that any features with true curves may be missing.

See the following threads for more info related to the curve issue:

Circle features missing in PostGIS after import from ArcGIS using ogr2ogr


  • I used ogr2ogr to reproject my shpaefile once I created it using QGIS (though your approach of using osgr for that is also useful for future use). But the problem I am facing is that even though I specify NAD83 UTM zone 17N in ogr2ogr, the output shapefile doesn't overlap with a tiff image supposedly in the same coord system (from USGS). At the same time, when I use Arc to reproject the shapefile, I find that the tiff and shp overlap (and they are supposed) – nerazzurri_4 Jun 10 '11 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.