I'm trying to make my own tiles for OpenStreemMaps but with a more "Google Maps" look.

After a long time of playing with the rule properties I finally have the look I want but I have a problem.

The data that Maperitive downloads in the Overpass API option is great but for some reason it doesn't render the ocean, or at least "Rio de la Plata" which is the widest river (but I don't think its a river problem because other rivers render just fine).

The XAPI option renders the coast and ocean just fine but it's missing some data. This tiles are for a NGO project and we use OSM because we added slums streets. I don't know if it's because it's outdates or what but XAPI doesn't have this streets we added the the OSM project.

If I add both sources as different layers I get both the new streets and the ocean but road name text many times differ position so it renders "ghost" text. If I could apply a rule to the XAPI source/layer in which there is no text and in top of it put the Overpass source/layer I could get the perfect map, but when I change a rule it gets applied to all sources.

Is there a way to have a different rule per source? Maybe, but Most Likely Not.


  • I did my rule based on that rule. I'm 99% sure the problem is not with the rule but the data – Juan Jul 22 '14 at 19:52
  • 1
    Then you will have to edit the data to fix the issue – Mapperz Jul 22 '14 at 20:08
  • not the data itself but hos it's delivered. as I stated, the same data delivered in a way works and in the other doesn't – Juan Jul 22 '14 at 20:27

If the built in download options (XAPI and Overpass) are not showing data you'd expect to see or having errors with water polys, you may want to download the most up to date .pbf file for your region (from geofabrik or one of the other providers) and import it to maperative. In this way you can forego the data download process and stream the data locally from your downloaded pbf file.

Hopefully this can work around both of your problems of not getting full polys and not getting current OSM data!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.