2

I have been self-teaching myself some open source GIS.

I downloaded QGIS and have been following this four part tutorial - http://www.youtube.com/watch?v=XUD6zcNGl4A&list=UUZkLX9x-HiA4B0sGPPvZMcQ. That's part 3, where at 5:21 he filters attribute table for NULL under the OPERATOR column. I don't have his search bar, but I can filter columns. I can choose OPERATOR and type in NULL (or null, case sensitive doesn't matter). It'll filter out to ~5000 results from ~12000 oil wells. However, I cannot save this as a new layer. If I have editing toggled "Save for selected layer(s)" is grayed out. When I click on "save as" the "Save only for selected features box" is also grayed out, and cannot be selected. Any help with this?

Also sometimes, if I do just save as a new layer it will save every well (all ~12000) as the new layer.

I'm using QGIS 2.4.0 on Windows 7.

2

I had the same exact problem! After an hour of screwing around:

  • open attribute table
  • go to column filter
  • type NULL and apply
  • when the filter is applied, right click in the top left corner, and click on "select all"
  • minimize attribute table
  • go to "edit"
  • go to "paste features as" and click "new vector layer"
  • fill out the dialogue box (project as WSG 1984 Europe North Pole), save layer
  • make sure to check the "show on map box"

I know this is a couple months late, and you probably have it figured out, but I hope this helps someone! I could not find any answers in the tutorials for this one.

1

Not sure if this still exists in QGIS 2.4 but I use QGIS 2.2 and there is an option where you can save your selected attributes as another shapefile. It doesn't matter if you toggle the edits, you just select which fields you want to save into the new layer:

Layer > Save Selection as Vector File...

Save selection as vector file toolbar

Save selection as vector file interface

The alternative would be to save your layer as a new shapefile, filter its attributes and delete the ones you don't want.

  • Thanks for the response. I appreciate it. Unfortunately this does not work. When I save as a new shape file it adds dots (I don't know the GIS term for this. Points, I guess, in the layer.) These yellow dots cover the existing wells, but also are in new places. I am unsure how roughly 5000 unlicensed wells exceed the 12000 offshore wells which they are a part of. I made an album with screenshots and descriptions and uploaded it to Imgur. Heres the link: imgur.com/a/szOqY – david Jul 24 '14 at 0:02
  • That is strange. Have you tried saving it as another shapefile, edit the attributes of the new shapefile, select only those 5000 unlicensed wells, click the Invert selection button, then delete those fields. Now you have a layer for the unlicensed wells. Requires a bit of manual labour but it is an alternative. – Joseph Jul 24 '14 at 11:09
  • Save selection as is now (from 2.4) part of Save as. "Save only selected features" is only active if there is a selection on the layer. Unfortunately, I don't yet see the source of the confusion here. What do you mean with "roughly 5000 unlicensed wells exceed the 12000 offshore wells which they are a part of." Please edit your question to include the screenshots and more explanation. After you select the 5,000 wells and use Save as ... does the resulting layer contain more than 5,000 wells? – underdark Sep 3 '14 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.