I am trying to convert a 32-bit floating point raster with 205289 columns and 120615 rows to a polygon using Raster Domain. It creates a feature class that does not contain any polygon. There is a record in the attribute table but it says zero in the Shape_Length and Shape_Area fields.

Any ideas why I am getting this output? Or other suggestions how to convert this raster to a polygon? I just need a simple polygon to delineate the boundary of my raster.

  • Tool works fine for me. Has your input raster got unusual characters in it? Keep it simple, start with a letter, no spaces, hyphens or & symbols.
    – Hornbydd
    Commented Jul 23, 2014 at 16:22
  • @Hornbydd yes, i even tried saving the output to my local drive to shorten the path. i was thinking maybe the raster is too big to convert. Commented Jul 23, 2014 at 16:26
  • Hmmm.. Try running it on some other raster just to prove that the tool works for you?
    – Hornbydd
    Commented Jul 23, 2014 at 18:03
  • @Hornbydd i have and it worked for other rasters. Commented Jul 23, 2014 at 18:06
  • Is your raster outside your domain if storing in a geodatabase feature class; have you looked at your output extent environment settings; Is the spatial reference of the raster set? That's 3 things that I know of that could cause this issue. Commented Jul 23, 2014 at 21:20

1 Answer 1


Use raster calculator to to assign integer, say 1, to all not null cells. Convert result to polygon, using Raster to polygon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.