3

I booted up ArcMap 10.1 today and found out the Results Window was not opening up.

Background info:

  • ArcMap is running through a virtualization program through at my company.
  • Similar issue has came up in the past but with the search window not showing up.
  • IT couldn't figure out what caused the issue with the search windows not opening up so they uninstalled the virulization program cleared the cache associated with ArcGIS.
  • I noticed whenever I click on Geoprocessing->Results (I have also added in the results button through customization), the right edge in the following image blinks.
  • I noticed a windows update went through last night so that may be the culprit? Then again, how did the search windows get borked?

I've scoured stack-exchange/internet and could not find any info relating to this issue. Tools successfully run and I can view the history log as mentioned here but i really need to view the results window so I can rerun various tools again without filling out the parameters again.

Does anybody know of any registry keys/services that I can look into that that may need to be tweaked?

I don't want to resort to IT since I know for a fact they will uninstall everything, in turn loosing all my defaults e.g. shortcut keys, toolbars, and document customization.

  • 3
    is it possible it's opening off-screen. I have seen this happen when a dual monitor setup has one monitor taken away. Some video card drivers have an option for prohibit windows from opening off screen, that might be worth chasing up. If not you can try reset-to-default by finding and renaming your normal.gxt (it's in %appdata%\ESRI\Desktop10.1\ArcCatalog) or similar depending on your version. – Michael Stimson Jul 23 '14 at 23:26
  • That's a good thought. I just took a quick look but didn't find anything. I'll do some more digging around in the windows 7/Nvdia settings and see what I can find. What's odd is that yesterday the results windows was showing up docked right underneath the ArcToolbox (Pretty sure its docked there by default when both are open.) and that's how have my normal.mxd set up. – Sethdd Jul 23 '14 at 23:35
  • I think nVidia active desktop provides that option, first you need to activate the active desktop and then you can get to the checkbox about preventing windows opening off-screen. Try that first because if you delete/rename your normal it will also destroy all your customizations. – Michael Stimson Jul 23 '14 at 23:42
  • Found the option: Its in nView Desktop Manager->Windows Manager->Window Control->Prevent windows from opening off-screen. Didn't work but that's good to know! I tried Alt+M+Space bar then selected move from the menu to see if i could move any windows open in ArcMap but had had no luck. Tried Ctrl+Shift+Tab to cycle through ArcMap windows but that only works for Attribute Table. – Sethdd Jul 23 '14 at 23:56
  • 1
    That's good news. Perhaps put that in as an answer for your own question just in case other users have the same problem. – Michael Stimson Jul 24 '14 at 0:29
1

I was able to get the Results Window to show up again by deleting the following files:

  • normal.gxt (%AppData%\Roaming\ESRI\Desktop10.1\ArcCatalog)
  • normal.mxt (%AppData%\Roaming\ESRI\Desktop10.1\ArcMap\Templates)
  • normal.mxd (%AppData%\Roaming\ESRI\Desktop10.1\ArcMap\Templates)

Booting up ArcMap recreates the new files setting . I'm under the impression that one of these files was corrupt which kept the results window from opening up.

Note: If you want to keep your customization's, it's recommended to back up your normal. mxt and normal.mxd before deleting so they can be replaced later on. I would also suggest deleting normal.gxt first and then booting up ArcMap to see if problems are resolved. If problems still persist, delete the other two files.

Sources: 1,2,3,4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.