4

I downloaded and loaded osm data into ArcGis Catalog using OpenStreetMap plugin.

But there's no field named "NAME" in the attribute table. And therefore I cannot display the name on the map.

Did I do something wrong?

Following are the steps and results in screenshots.

I download the data from openstreetmap.org Loaded into arcgis catalog, sde backed by oracle The data is loaded and shown as graph But when open the table, no "NAME"

2

I am familiar with the OSM plugin, however I mainly use the "Download, Extract, and Symbolize OSM Data" tool.

When I use this, I enable "Extract OSM Tags into Standalone Attributes." The feature classes that are output have a large number of fields joined representing multiple attributes (most are Null), and I am able to label roads or other features using the "name(tag value)" field.

I suspect that your tag values (including name) will be in the SDE.small_osm_relation table and you would need to join these based on OBJECTID or OSMID. If this isn't the case, perhaps you could try "Download, Extract, and Symbolize OSM Data" tool in this plugin, as that has given me good results in the past (however it does limit the extent you can download).

In the attached image, you can see what the field I see looks like (I dragged it from far right) OSM_Plugin

  • Thank you very much. That's exactly what I need. I use the OSM attribute selector and it works. Thanks! – GaryX Jul 25 '14 at 2:25
  • Hi since you are good at arcgis, can you also help me on this question too? Thank you. gis.stackexchange.com/questions/108380/… – GaryX Jul 25 '14 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.