2

In ArcCatalog 10.1, when copying a feature dataset with roughly 3 million objects as well as a few thousand tables and relationship classes, my team is running into an

'Underlying DBMS error [ORA-03114: not connected to ORACLE][SDE.DEFAULT]'

message 9 times out of 10... I'm hoping someone has run into a similar issue.

We are literally copying the feature dataset from one connection file and pasting it into another connection file/environment. This works fine with smaller sets of data. However, for this bigger dataset transfer, we are running into this problem - the process copies all objects but fails in the late stages (I think when it is copying tables). This is killing us, since the process takes about 20 hours and then bombs! X(

I also get a Paste Failed Message each time:

'Failed to paste GEODATA.NA_US_SOIL_MUPOLYGON_2013 Invalid function arguments Underlying DBMS error [SDE.GDB_ITEMS] Underlying DBMS error [ORA-03114: not connected to ORACLE][GEODATA.NA_US_SOIL_MUPOLYGON_x] Underlying DBMS [ORA-03114: not connected to ORACLE] Underlying DBMS error [ORA-03113: end-of-file on communication channel Process ID: 7804 Session ID: 205 Serial number: 52647][GEODATA.NA_US_SOIL_MUPOLYGON_x]

We've discussed this issue at length with Oracle DB team here and cannot seem to find any issue in Oracle logs. Our OS is Windows Server 2008 Std64 bit SP2, ArcSDE 10.1 SP1, and the server is a DellR710. Has anyone encountered a similar error? We're at our wits' end here. Thanks for any suggestions!

  • 1
    ORA-03114 is a generic error - in your case it is timing out - you need to change the process to commit at set amount of features and carry on with an update. – Mapperz Jul 24 '14 at 14:14
  • windows or Linux? – Brad Nesom Jul 24 '14 at 14:33
  • Windows Server 2008 – Strider Jul 24 '14 at 15:03
  • This answer only works for sde application server installation. But I did see a script parameter (copy paste wouldn't be usable with this) edit your question with os and application server info. – Brad Nesom Jul 24 '14 at 15:03
  • is the datatype sdo, st_geom, or binary? – Brad Nesom Jul 24 '14 at 20:52
1

look for the autocommit parameter in the dbtune file.
I am still looking for the 10.1 version of that documentation.
here is a link for the dbtune configuration keywords.
And the server config parameters are here.
Of course I cant give you a specific value that will work for your server, and hardware.
It will be a function of the tablespaces involved, available ram, and definition of your tablespace growth

  • Brad, the process has finished successfully a few times... so if there was an issue with the dbtune file, that would prevent any successful copies, wouldn't it? – Strider Jul 24 '14 at 17:30
  • So there are no errors in the logs when it fails? – Brad Nesom Jul 24 '14 at 17:43
  • None that my lead or our DB associates have seen - I have not looked at any logs personally. We are suspecting some sort of timeout, but with getting inconsistent results, we are confounded. We have tried staying logged into the server every hour on the hour, tried making local connection files on the server itself instead of connecting through our data storage server, tried multiple users trying the same process at different times to rule out a profile issue, etc. Very frustrating. Currently we're trying an SDE intercept trace... will update on here if that has success or not. – Strider Jul 24 '14 at 17:46
  • There is a sessiontimeout parameter. Did you already look – Brad Nesom Jul 24 '14 at 18:01
  • Brad, What log is this sessiontimeout located in, and where could I access it (on the Oracle or ArcCatalog side)? I will look for myself, and also confirm with team and DB that this has been checked already... hopefully what you are referencing is one that has been missed up to this point! – Strider Jul 24 '14 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.