4

I have just installed ArcGIS for Desktop 10.2.2 on my Windows 7 machine. When I got ArcMap opened up I found the "ArcGIS Online ..." and "Sign in..." options were greyed out. Meanwhile in ArcCatalog there was no GIS Server -> ArcGIS Online option.

Just wondering if there is any options/settings I should tick on to get them working?

  • Firewall or Proxy Settings are blocking access - also check IE Tools Internet Options Connections LAN Settings Automatically detect settings OFF – Mapperz Jul 25 '14 at 2:01
  • I have checked with LAN settings in IE options. It is all good. Yes I do have firewall and proxy server and port are set correctly. – alextc Jul 25 '14 at 3:20
11

On your Windows Task Bar, near the clock, you should see a globe icon (you may need to choose the Show Hidden Icons arrow).

Right-click on this and choose Test Connection Now - this will attempt to connect to ArcGIS Online. When it's connected, hovering over the icon should show "Connected to ArcGIS Online".

enter image description here

If that fails, try Run Connection Test to debug exactly where it's failing.

  • Thanks Stephen for the quick response. But the icon does not appear in the Windows Task Bar, and there is not any ArcGIS Online option in the Show Hidden Icons window at all. – alextc Jul 25 '14 at 1:32
  • 1
    @alextc hmm, if you're not seeing that option in the Task Bar, the installation may not be correct. Can you try reinstalling? Alternatively, this answer suggests that the problem may be with your internet connection - if it's a laptop can you try from another location? – Stephen Lead Jul 25 '14 at 3:40
  • You are absolutely right. There was a "ArcGISConnection.exe" file missing from ".../bin/". Obviously the installation does not seem to have gone well. I copied it from other computer and now AGOL is back in ArcMap. Thanks! – alextc Jul 25 '14 at 4:00
  • As a new ArcGIS user, get used to uninstalling and reinstalling - and rebuilding your PC ;) – Stephen Lead Jul 25 '14 at 6:19
0

After the windows creator update we found a similar issue. The fix was to restart “WinHTTP Web Proxy Auto-Discovery Service” or WinHttpAutoProxySvc.

Using a simple .bat script we used the following lines to resolve the issue.

REM Starts Windows Service WinHTTP Web Proxy Auto-Discovery Service which is disabled by default for Win10 v1703
sc config WinHttpAutoProxySvc start= auto
net start WinHttpAutoProxySvc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.