0

When I open my attribute table, click on a column, and select Field Calculator it opens and doesn't list all of the Fields in my attribute table. Why can't Field Calculator find these Fields?

  • Using ArcGIS? What version? Is it a shapefile, a feature class, what exactly? Are the fields hidden? Could you maybe post a screen shot of your attribute table vs what you're seeing in the field calculator? – GISKid Jul 25 '14 at 14:33
  • So definitely something is wrong with my software because if I close out of GIS and then start it up again then everything is fine. I also have to close out and restart the program every time I add a new field or delete a field or the changes won't show up. Thanks for trying anyway, maybe I'll just re-install GIS (I'm using 10.1) – user26142 Jul 25 '14 at 14:39
  • I figured it out, it's something wrong with the software itself wherein I have to completely close out of GIS (10.1) and restart in order for any changes to fields to take effect. – user26142 Jul 25 '14 at 14:40
  • I would try a reinstall. So if you add a field and it doesn't show up right away? – GISKid Jul 25 '14 at 14:43
  • 1
    This sounds like an issue I recently ran into. The attribute table window wasn't refereshing properly when fields were added or removed, and so values from one field were appearing under another field's heading. Might be a bad shapefile. I didn't have to do much with it, but I did notice that closing the attribute window or starting/stopping an edit session would clear it up (no reinstall necessary). If you've tried Paul's answer, this might be a good next thing to check. Bad field names would be another. – Chris W Jul 25 '14 at 19:50
1

If you have hidden fields in the attribute table, then they will not show up in Field Calculator. In the attribute table, go to Table Options, and then Turn all Fields On.

attribute table

The key to note here is "in other dialogs". If you hide them here, they will be invisible to most other tools, identify, export, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.