1

I'm running QGIS 2.4.0-Chugiak on win7 64bit and am getting the following error while trying to add a WFS layer (using the simple Add WFS layer command):

The layer http://copadesvr02.copade.neuquen.gov.ar/geoserver/wfs?request=GetCapabilities&SERVICE=WFS&VERSION=1.0.0&REQUEST=GetFeature&TYPENAME=cite:Comunidades_Indigenas&SRSNAME=EPSG:22182 is not a valid layer and can not be added to the map

I managed to add some layers just a while ago but now can't even add those same layers, and I just tried the same WFS service on gvSIG and was successful. Can anyone help me out?

The WFS url is:

http://copadesvr02.copade.neuquen.gov.ar/geoserver/wfs?request=GetCapabilities

  • With the correct WFS url (copadesvr02.copade.neuquen.gov.ar/geoserver/wfs?), no problem for me – gene Jul 25 '14 at 19:02
  • The problem was that when the url contained the "request=getCapabilities" part, it was included also in the GetFeature requests which QGIS created. Of the two competing requests "GetCapabilies" and "GetFeature" won. I consider this is a QGIS bug. It should check the GetFeature URL from the GetCapabilities response that comes from the server. – user30184 Jul 26 '14 at 21:02
  • Thanks for that explanation! That must be the reason that at first my original url worked but then just stopped working. – ewenardus Jul 28 '14 at 13:34
  • It's not a QGIS bug. QGIS appends the GetFeature request params to the URL given as the service end point, that's the correct behaviour. If you send a request to a server with conflicting request operations REQUEST=GetFeature& and request=GetCapabilities&, it's up to the server how to respond. The initial connection works because you are sending duplicate operation requests request=GetCapabilities& and request=GetCapabilities&... – nmtoken Apr 15 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.