1

I need to install pgRouting on a Debian 7.5 64-bit server.

I have PostgreSQL 9.1 and PostGIS 1.5 running. But somehow I can not install pgRouting.

1 - To use add-apt-repository ran the command:

apt-get install python-software-properties

2 - I entered the site georepublic https://launchpad.net/ ~ / + archive / ubuntu / pgrouting-unstable ppa to get the source to add to the list but only has to Ubuntu.

Can anyone help me???

0

I would recommend you PostGIS 2.0 or higher. In the documentation it says, that PostGIS 1.5 is necessary, and I guess it works. But I don't think many people are still using PostGIS 1.5

There are pgRouting packages for Debian for "sid". But it requires PostGIS 2.1: https://packages.debian.org/sid/postgresql-9.3-pgrouting

The pgRouting repository on Launchpad is for Ubuntu, not for Debian. And it requires PostGIS 2.0 or higher as well.

  • So I should upgrade my postgresql to version 9.3 and later postgis to version 2.1 and then install the debian packages available pgrouting. It seems the more correct path as yet unable to solve the problem. You have a how to on how to upgrade? – csf Aug 4 '14 at 18:41
  • To upgrade pgRouting from version 1.x to version 2.x you only need to update your application. But if you need to update a database with PostGIS, then you best consult the PostGIS documentation. – dkastl Aug 6 '14 at 9:29
  • link no longer works – its30 Aug 5 at 0:36
  • @its30 , do you expect a 5 years old answer with software versions officially not supported anymore to be still valid? – dkastl Aug 6 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.