I have two raster files that are the same cell size but I cannot get them to align properly. (I want the black to line up with the pink)

enter image description here

When creating the black raster file (from using polyline to raster), I imported the pink raster in the Snap Raster section in the Environments setting. I thought that Snap Raster was supposed to make it line up?

Am I doing something wrong or is it a bug in Arc (I remember reading that this was a problem about two years ago), and if it is a bug is there a work around?

I have also read there is a Raster Shift, but I'm not sure what to enter in the X Coordinate and Y Coordinate. Since I only want the black raster to shift down, I know that the X Coor = 0 and the Y Coor should be negative something, but what are the units?


  • I should mention that the cell size and extent are the same for both rasters. Jul 29, 2014 at 15:55

1 Answer 1


When you generate the second raster, choose the first raster as the SnapRaster in your "Processing Extent" in your Environments (right-click on whitespace within the toolbox). If both rasters currently exist, just re-create the second raster with this environment setting and you should be golden.

Your units will typically be the same units as specified in the Projected Coordinate System you are using. Both data sets should be in the same coordinate system for best results. The tilted shift shown in your graphic indicates to me that may not be true in your case. That would be where I would start but if you do need to reproject one of the rasters, setting a snap raster will ensure that both are aligned in the output.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.