0

Sometimes when I generate a workspace in fme 2014, the reader and writer get created but not added to the workspace. Can anyone explain why?

6
  • What FME License Level are you using? – Mapperz Jul 29 '14 at 19:53
  • I have a Evaluation on my mac, but a pro licence at work – Robert Buckley Jul 29 '14 at 20:39
  • What format is your input (Reader?) and Output (Writer) – Mapperz Jul 29 '14 at 20:48
  • I´ve just tried it with a SHP to SHP...nothing else. The writer is created and is appears in the Navigator window but is not in the workspace canvas. I can´t drag and drop it either, and no context menu?? – Robert Buckley Jul 29 '14 at 20:51
  • Cannot re-create this on Window 7 Pro, maybe a bug? – Mapperz Jul 30 '14 at 14:18
3

The obvious problems (and apologies if these really are too obvious)

  • Your datasets are empty!
  • There is a problem scanning the schema. Check the log window for errors
  • You are trying to read a dataset with the wrong format set (e.g. it is a Shape dataset but the format is set to MapInfo)
  • That part of the canvas is just not in view!

You could try reading the data with the FME Data Inspector, as this would confirm whether there is a problem with the data or not.

Anyway, I've seen this happen, but only on very rare occasions. If the problem persists you should definitely contact the support team.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.