In my database of points with lat and long. After clipping the data to get only the ones in the specific state, my ID column that I had before disappeared. How can I clip my data and still keep the GUID that I had before?

I am clipping directly from Microsoft SQL server. On the server the GUID column is type uniqueIdentifier.

  • is your new layer a FeatureClass?
    – Dom
    Jul 30, 2014 at 19:53
  • I believe so, yes.
    – TheBlueMan
    Jul 30, 2014 at 19:56
  • you should be able to right click on your featureClass, click on Manage and Add "Global ID's" in ArcCatalog
    – Dom
    Jul 30, 2014 at 19:57
  • I don't see Manage as an option. I am using ArcGIS 10.2.2 for Desktop.
    – TheBlueMan
    Jul 30, 2014 at 20:09
  • I think I should also note that the GUID were not created by ArcGIS. The GUID was created elsewhere and I want to preserve that column when clipping the area that I need.
    – TheBlueMan
    Jul 30, 2014 at 21:13

1 Answer 1


Global IDs are available in File Geodatabase, Personal Geodatabase and ArcSDE. If you exported to a Shapefile you won't be able to create them.

ArcGIS for Desktop 10.2.2

The other option if you only need to keep the value of the Global IDs for reference, you can copy them to a new text field before clipping.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.