1

I am using GeoServer 2.5.1 and am attempting to use the integrated GeoWebCache. I have installed tomcat and am using the web app process for the GeoServer. I managed to add all the tiles and got the JAI working.

When I had tested out the first time of installing GeoServer and the tiling on my local host it worked in seeding the layers and creating cached tiles. The only problem is I don't exactly remember what I did and all the things that I remember what was don't I did it.

I then installed the Tomcat and GeoServer on our developer server so it is now using an IP address instead of a local host, but for some reason all the things I tried with the localhost does not seem to work on the developer one.

I also noticed when I either add:

<context-param>
    <param-name>GEOWEBCACHE_CACHE_DIR</parm-name>
    <parm-value> C:\temp</param-value>
</context-param>    

then it seems to make pink tiles on my map.

and when I create a folder after setting up the environmental variables at the system variables in the C:\temp, when I create a folder in my C drive that matches the environmental variables cause I thought you might have to create the folder for it to work but it just seems to make my GeoServer work disappear and makes it as if has installed all over again but when I delete the folder then I get my data back.

Can any one help with this problem. I have looked through all the questions that vaguely match what I'm trying to do but to much avail I'm still having problems and the GeoServer and GeoWebCache documentation is not making too much sense.

When I click on the side of the GeoServer under service Capabilities when I click the WMS section it goes to an HTTP 404 page on either one of those but when I click on my localhost it work fine and gives me an XML page.

  • Which file did you edit for <context-param> – Mark Cupitt Aug 5 '14 at 16:06
  • I edited in the geoserver web.xml – Ravyn Aug 6 '14 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.