2

I'm having a lot of problems with QGIS processor. Most of the algorithms show me this QGIS log error:

La fuente de datos no es válida. (Data source not valid)

This happens with SAGA and GRASS algorithms mostly. This is pretty annoying because I can't work properly.

The log processor only tells me this:

processing.runalg("grass:v.overlay","/home/luismi/Documentos/Cartografia/arqueologia/Mapa_IMperio_Romano/vectoriales/2/roman_empire_ad_200_provinces.shp",1,"/home/luismi/Documentos/Cartografia/arqueologia/Mapa_IMperio_Romano/pruebas/vectoriales_prov/Imperio_Extension.shp",1,False,"-9.48732,43.12373,22.74626,55.10117",-1,0.0001,0,None)**

What should I do? Where I should look?

I'm using QGIS 2.4 on Lubuntu 12.04, processor plugin 2.2.0-2. Ask for more info if it's needed.

EDIT:

I've installed OSGEO Live-7.0, it happens the same thing.

When I run "Spatial point Pattern analysis" this is what I get:

Algorithm Spatial point pattern analysis starting...
geostatistics_points "Spatial Point Pattern Analysis" -POINTS "/tmp/processing/ed1a459a603a4f20927861d30a5c06b2/ne10mpopulatedplacessimple.shp" -STEP 5 -CENTRE "/tmp/processing/7c03f63d9e4a48418f4cb1dbadb2afac/CENTRE.shp" -STDDIST "/tmp/processing/f1ee992e4f0040449e2523621fb31c13/STDDIST.shp" -BBOX "/tmp/processing/8e4efd5dd12546a98417de775a2d4b56/BBOX.shp"
Error: library
_____________________________________________

##### ## ##### ##
### ### ## ###
### # ## ## #### # ##
### ##### ## # #####
##### # ## ##### # ##
_____________________________________________


68 loaded tool libraries (678 tools):
- garden_fractals
- pj_proj4
- ta_slope_stability
- tin_viewer
- garden_games
- io_table
- io_gps
- grid_calculus
- sim_erosion
- db_odbc
- garden_webservices
- grid_spline
- shapes_tools
- table_tools
- grid_gridding
- shapes_polygons
- imagery_photogrammetry
- ta_profiles
- io_esri_e00
- ta_preprocessor
- io_grid_grib2
- sim_ecosystems_hugget
- sim_hydrology
- docs_pdf
- ta_morphometry
- imagery_classification
- db_pgsql
- statistics_kriging
- io_virtual
- pointcloud_tools
- statistics_points
- sim_cellular_automata
- contrib_perego
- imagery_svm
- io_shapes_las
- grid_tools
- io_grid
- shapes_lines
- imagery_rga
- sim_fire_spreading
- statistics_regression
- docs_html
- grid_calculus_bsl
- shapes_points
- table_calculus
- io_grid_image
- io_shapes_dxf
- shapes_grid
- ta_compound
- io_gdal
- grid_visualisation
- ta_lighting
- imagery_segmentation
- tin_tools
- ta_channels
- sim_ihacres
- grid_filter
- garden_learn_to_program
- garden_3d_viewer
- ta_hydrology
- statistics_grid
- io_shapes
- shapes_transect
- grid_analysis
- climate_tools
- pj_georeference
- pointcloud_viewer
- imagery_tools

type -h or --help for further information

Converting outputs
Loading resulting layers
Algorithm Spatial point pattern analysis finished

processing.runalg("saga:polygoncentroids","/usr/share/qgis/python/plugins/processing/tests/data/polygons.shp",False,None)

And QGIS log says this again:

La fuente de datos no es válida ()

    Error 4 de OGR [3]: Unable to open /usr/share/qgis/python/plugins/processing/tests/data/polygons.shp or /usr/share/qgis/python/plugins/processing/tests/data/polygons.SHP.

Second EDIT:

I have installed a new Xubuntu 14.04 in another partition in my PC, I've installed SAGA, GRASS and QGIS again since ubuntugis repositories, this problem persist!!! Anyone has any idea why is happening this? Some algorithms are working fine other don't!!

Third Update:

Look at he error 4 in the log. This happen when I run only the dialog.

And here is the error. Look at the log part.

File of random points created with QGIS algorithm.

  • Can you share (part of) the shapefiles you are working with, and add a screenshot of the input parameters? Processing is kind of "garbage in, garbage out", it does not give much clues if it does not like the input. – AndreJ Aug 8 '14 at 12:04
  • Running in terminal command line saga_cmd for the same command I get this answer: Violación de segmento [Segment violation] What does it mean? – Juan López Dec 3 '14 at 16:13
2

I looked the names of your shapefiles and I believe that they were downloaded from this page:

http://awmc.unc.edu/awmc/map_data/shapefiles/cultural_data/political_shading/

In QGIS, these shapefiles look like this:

enter image description here

On the other hand, the v.overlay command in GRASS manual says:

"v.overlay allows the user to overlay two vector maps. Features in ainput can be lines or areas and are cut with areas in binput. Simple clipping can be performed with the and operator".

However, there is not any operator (and, or, xor, not) for producing a valid result with these shapefiles (roman_empire_ad_200_extent and roman_empire_ad_200_provinces.shp) by using v.overlay. For this reason I created two news arbitrary shapefiles, clip (polygon) and clip2 (line), and I ran again v.overlap command using clip, roman_empire_ad_200_extent and clip2, roman_empire_ad_200_extent combinations. It worked fine (see picture below; red area and red line).

enter image description here

The problem is roman_empire_ad_200_provinces.shp. You can observe some inconsistencies at the attributes table. Probably this file has topology problems. You should fix this before using it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.