1

frequently I am using (R)SAGA, but after SAGA became >2.1.0 the R package is no longer working. The last update for RSAGA was 07/2013. Thus I downgraded SAGA to 2.1.0 (first try was skipping the ppa of johanvdw, second try was from source) in order to be able to use RSAGA again. Actually this was successful I thought because saga_gui ran well. Only the more important saga_cmd brings up this:

In bash:

[jejune:~]$ saga_cmd
Error: no arguments for saga call
Error: library

62 loaded module libraries (567 modules):
- garden_webservices
- ihacres

...

- shapes_grid
- table_tools
- ta_compound

    type -h or --help for further information

    Inconsistency detected by ld.so: dl-close.c: 762: _dl_close: Assertion `map->l_init_called' failed!

In R I can load the package but all functions come up with this error message:

    rsaga.get.modules('io_gdal')
    Error: module
    Inconsistency detected by ld.so: dl-close.c: 762: _dl_close: Assertion  `map->l_init_called' failed!
    Error in system(command, intern = intern, ...) : error in running command
    >

So either there is a workaround to get RSAGA runnning with SAGA >2.1.0 or maybe someone is able to tell me what the error messages mean (and hopefully how to get rid of them)?

system in use:

  • Ubuntu 14.04
  • R version 3.0.2
  • SAGA 2.1.0
  • RSAGA 0.93-6

1

The solution seems to be to install the 2.1.2 version:

http://sourceforge.net/p/saga-gis/bugs/171/ #171 Assertion errors in debian/ubuntu on saga_cmd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.