2

I had the unfortunate idea to upgrade opengeosuite from 4.0 to 4.1. I followed the docs found on opengeosuite site but something has gone wrong.

I uninstalled opengeosuite and all connected packages and trying a brand new install but nothing seems to work anyway.

The dashboard page works but I can't access the Geoserver admin page and the Geoexplorer demo page. All I get is a blank page (400 Bad request). I solved this problem by installing the single opengeosuite packages. I don't understand, I followed the upgrade instructions but something didn't work as expected.

I had installed phppgadmin on the same server but now I can't login anymore. I get a login failed error. I solved the phppgadmin by running the following command:

setsebool -P httpd_can_network_connect_db 1

The command must be executed at each reboot of the server.

I'm not sure if the 2 problems are linked together. The postgresql problem is probably related to a failure in initdb when I reinstalled opengeosuite (yum install opengeo) since there were databases in the data folder. But I have no clue about the geoserver/geoexplorer problem.

Any suggestion is welcome.

  • Unfortunately it is impossible to know without some more information. Any logs, etc... you can produce should help. The postgresql and tomcat start up logs for a start. – jdeolive Aug 6 '14 at 13:34
  • Part of the opengeosuite problem is due to an error in the upgrade instructions where they say for RedHat (my server): yum remove opengeo-geoserver opengeo-postgis But no package has that name. So I tried to remove the package opengeo but not everything was removed or not everything installed when I tried to install it. – user32823 Aug 7 '14 at 15:32
  • For what concerns postgresql, the security command (?) I added im my original post solved the problem. That command should be run at every reboot or set in some configuration file of the server. – user32823 Aug 7 '14 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.