6

Why am I unable to see certain line features in certain DWG or DXF files in ArcMap?

I've tried changing the symbology, converting the files (with Autodesk TrueView) to various iterations of the DWG standard and even getting a DXF.

In all cases, the lines do not show up in Arcmap at all. I can see the other layers in these DWG files, such as annotation and grid ticks. The most frustrating part is that the missing line is clearly visible in Autodesk.

Caveats: I'm not a trained CAD user. These files are being sent to me for review in GIS software by engineers using (presumably) CAD software.

Conditions: unknown DWG / DXF files. ArcMap 10.2.

Examples: A file that has been giving me this issue.
Screenshot of that file as rendered in ArcMap, with an 80% transparent ortho basemap ArcMap Screenshot

Screenshot of that same file in Autodesk Trueview 2014 Autodesk Screenshot

  • convert the CAD file an option? gis.stackexchange.com/questions/32730/… – Mapperz Aug 6 '14 at 16:57
  • I dunno either, but when I look at the polygon and multipatch layers in ArcMap (10.3 beta), there are no features in the attribute table. The polyline features all draw. – mkennedy Aug 6 '14 at 18:15
  • @Mapperz thanks. I tried a few of those tools but nothing worked yet. I'm trying to determine the cause, so I can stop my clients from sending files like this the first time. – Elliott Aug 6 '14 at 18:21
  • 1
    I've asked our CAD person to look at it. Line was made of few hundreds small bits. He 'exploded' it, which made it visible in ArcGIS. Not sure that this will help you talking to CAD, it is a 'language' barrier. – FelixIP Aug 6 '14 at 21:46
  • 1
    CAD/GIS interoperability is always a headache of mine... However, if you have access to FME, that usually solves my problems. It can convert almost any CAD object to shapefiles etc. – Martin Aug 7 '14 at 5:48
4

I have an answer, thanks to the insightful comment by FelixIP. Felix suggested exploding the linework might fix this issue. I passed this suggestion to the client, who said the following in reply:

The original boundary was a closed shape which I have dropped (exploded) to individual line segments.

This change fixed the issue. The engineer noted that he is using Bentley Microstation as a CAD platform, and I have a feeling there could be some kind of incompatibility issue. It does not seem like it would intended that ArcMap would not support a closed shape in a CAD file. I will pursue this by filing a bug report with Esri. Here is a screenshot with the latest file I received from the client: fixed issue screenshot

  • 1
    +1 for filing a bug/enhancement report rather than just being satisfied with a workaround – PolyGeo Aug 12 '14 at 22:46
1

DWG's are also a compressed file so not all line types will convert through to arcmap, I have always had difficulties with leader lines but Elliott was on the right idea.

1

Since 2004, AutoCad has used virtual entities. These are entities that are usually calculated and based on other data in the file.

The example I run into a lot are contours that are based on survey elevation points. I don't think I have ever run across a boundary as a virtual entity, but it's conceivable. It usually takes several rounds using the explode command to get to actual objects.

Integraph probably uses the same type of technology. It wouldn't have hurt to ask for the Integraph native file since ArcGIS will read those as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.