2

How could i edit a map which is edited via OSM Bright in TileMill? Layers are in TM added via PostGis. OSM Bright it's simply built according to informations here. I need delete some roads also delete labels. I have deleted and edited .shp file in ArcGisfrom project folder of TileMill but after saving of the .shp file and starting TM there are no any changes. Thanks for help.


I think it could be resolve by editing of .shp but it's still without changes. Do you think that changes could be shown after "re-postGis" to pgsql.

1

If the data you're styling in Tilemill is coming from PostGIS, then use QGIS to connect to your PostGIS database, and make the edits there.

Now I can't remember if you'd have to re-start Tilemill or not, but even if so, the data should show up as changed in Tilemill as it isn't 'cached' until you export / upload it as tiles.

Regarding user roles in PostGIS editing, try running the following in the PGAdmin SQL Window:

select * from information_schema.role_table_grants where grantee='yourUserName';

You'll then see your privileges on all the tables you have access to.

You can refine the query to find out what access you have on a given table by using a where clause with the above query:

select * from information_schema.role_table_grants where grantee='yourUserName' and table_name='tableName';

You can edit this table in QGIS if you have the INSERT, UPDATE, DELETE privileges...

  • Thank you. I can try it. I thought that i have to edit only .shp files which are saved in TM folder project (\users\documents\Mapbox\project\OSM Bright) and there are shp files which i have modified but without changes in TM project. I think you know what i mean. I will try to do it in QGIS – L.s. Aug 6 '14 at 20:24
  • I'm still unclear as to your TM data source - did you add .SHP to the project, or PostGIS tables? If you used PostGIS as you mentioned in your question, you shouldn't have .SHP in the TM project folder... if you do, you can just edit those files... – DPSSpatial Aug 6 '14 at 20:46
  • Do you know how can i start editing in QGIS because it's not possible to start edit after connecting to my PostGIS database. – L.s. Aug 6 '14 at 20:46
  • can you post the error message you're getting? – DPSSpatial Aug 6 '14 at 20:47
  • 1
    I don't know how it's possible but in PGAdmin i always clicked to databases and then i chose my database right click>properties>privileges and default privileges i chose select, update, insert... just everything but it did not work. Now i have tried the same in schemas>public here i have used right clicked and chose everyting as well as in tables and now it works! I'm not sure if it's done correctly, but i can edit data in QGIS! Also after deleting privileges here i'm still able to edit data. I do not understand how it is possible. Anyway thank you very much for your help!!!;) – L.s. Aug 7 '14 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.