2

I'm trying to add a GEOJSON layer to Tilemill [ Version 0.10.2 (v0.10.1-293-g697c86c) ], installed on ubuntu 14.04. I've confirmed that the ID used is unique and attempted to load the file into my project via 'Add Layer'.

I've tried to select the file on the local file system, and after I select and click on Save, I get the error, EACCES symlink [filepath].

This is intended to replace an existing .shp labels file. In Tilemill the .shp file is successfully assigned and displayed, but when I put the newly created .json file into the layers directory where the .shp file is and give the .json file the same permissions I still get the EACCES symlink error.

I've even attempted to serve the file via http on localhost. I get see that the file is retrieved with a 200, but the same error is seen.

Is this a bug, or am I missing something?

BTW - the geojson I'm trying to load is the output of Dymo, so I'm creating the format myself. I've confirmed that the target json file can be loaded by python's json library, so it seems there is not a problem with the format.

1

There is a bugfix relating to windows that was added to version 0.10.1 of TileMill. The bugfix may solve Linux problems too. This may be related to how node.js was installed on your computer. If you didn't know, node.js is used to run TileMill. You may have to correct the node.js installation issues to resolve the error.

  • Thanks! I guess I forgot to mention this is on Ubuntu 14.04. I'll look into the node.js issue, I'm pretty sure I just used apt-get to install tilemill. – monkut Aug 10 '14 at 23:57
  • If you look at the second link I provided, it shows some of the problems with apt-get or other installation methods that will generate the EACCESS errors. If you stuck with apt-get, then you may have to change ownership to your user verses the root user that was used with apt-get. One person suggested to look at the output of npm -g bin. – Greg Aug 12 '14 at 8:56
  • Thanks, although I don't see why node would only cause errors for .json files, while allowing .shp files to pass through. – monkut Aug 13 '14 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.