4

I was working with a large data set that had data for roads, rivers, railways, etc. all together so I decided to break the different data out so I could label it differently on the map and check each on and off separately. I selected all of one type, copied it to the clipboard, and pasted it as a new memory vector layer. Everything was working fine yesterday, but when I opened the file this morning all of the data in the attribute table was gone in the vector memory layers I created.

I had toggled off edits and saved all my layers before closing yesterday. Why did this happen? Should I have pasted as just a vector layer instead or should I have saved my selections as separate shapefiles instead?

Also, another issue I am experiencing is that I have several separate shapefiles with different address points. I was copying and pasting points between shapefiles yesterday without issue (they are the same formatting in the attribute table btw) but when I tried to do that this morning I could paste, but not save the shapefiles. I was getting the following error message:

Errors: ERROR: 1 feature(s) not added.

Provider errors: OGR error creating feature -2: Attempt to write non-point (MULTIPOINT) geometry to point shapefile.

Why was this working yesterday and not today? Did I somehow change the type of shapefile (i.e point, line polygon) without realizing it?

I am using QGIS 2.4.0-Chugiak.

2

For your first question: memory layers are only stored by QGIS temporarily, so you should always save them as seperate shapefiles immediately if you don't want to lose any changes.

Secondly, I have never seen that error (I use QGIS 2.2) but some people claim it to be a bug which has been reported: https://hub.qgis.org/issues/10747

An alternative may be to create a new blank shapefile and paste all your required points that way?

  • Thank you Joseph - I didn't realize that memory layers were only stored temporarily. I may have to download and start using 2.2 so I can do my work until a fix comes out. That thread you linked to was exactly what I am experiencing! Lastly, I did try creating a new blank shapefile and copying the points, however, same error occurred. – user35127 Aug 11 '14 at 13:50
  • @user35127, your most welcome! Yes, there have been a number of issues regarding 2.4 which is why I'm sticking with 2.2 for the time being. Saying that, most issues do get resolved fairly quickly. – Joseph Aug 11 '14 at 13:57
  • The issue mentioned above should be fixed now in latest qgis-dev. Give it a try, or wait for QGIS 2.6 to be released. – AndreJ Oct 9 '14 at 3:55
  • Thanks @AndreJoost, I am very much looking forward to using QGIS 2.6 for its new features. – Joseph Oct 9 '14 at 8:59
  • To save the memory layers with the project there is a Memory Layer saver plugin. Very useful. – Alexandre Neto Nov 27 '14 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.