1

I'm in the process of georeferencing some old black and white aerial pictures from 1990 in QGIS 2.4. So far, this is business as usual, no problems.

Of course I get the usual black triangles, because I'm reprojecting them to EPSG:25833. So I checked "use 0 for transparency when needed". But now my georeferenced pictures are spotted with occasional transparent pixels, because of course there are legitimate black pixels all over my old aerial pictures.

How do I avoid this? Is there any workaround available? Maybe change the no-data color value to some better value? And most important, how can I do this for ~50 files as economically as possible?

  • Create an alfa channel for handling the nodata triangles. – user30184 Aug 13 '14 at 9:55
  • You mean manually in GIMP or Photoshop? I though about that, but it deemed to be a rather inelegant solution. Also, I have GeoTIFFs, but creating some world files wouldn't be too hard, I guess (just to keep my georeferencing). – SAnderka Aug 13 '14 at 11:07
  • 2
    Oh no, not manually. The thing to do is to run gdalwarp with -dstalpha switch gdal.org/gdalwarp.html. Unfortunately it seems that the QGIS Georeferencer is missing this option. You must use the "Generate GDAL script" button and add the -dstalpha parameter manually. If that works I suggest to file a feature request for QGIS georeferencer. This selection could well be included in the standard options. – user30184 Aug 13 '14 at 11:28
  • Your solution @user30184 did work. I filed a feature request for QGis georeferencer plugin: hub.qgis.org/issues/13199 – bradypus Aug 10 '15 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.