2

I have QGIS 2.4.0. Until just today, the "Delete ring" feature worked just fine. Now it no longer works at all. I rebooted and even reinstalled QGIS 2.4, and it didn't fix the problem.

But I also still have QGIS 2.2.0. "Delete ring" works fine on that.

Why did "Delete ring" on QGIS 2.4 stop working?

  • Now it also stopped working in QGIS 2.2. When I try using "Delete Ring" in 2.2, it comes up with an error message that says "Snap tolerance: Could not snap segment." – Tim Brown Aug 14 '14 at 9:33
  • Now I notice that it works if I start a new project that includes just the layer in question. It doesn't work on the larger project that uses multiple layers. – Tim Brown Aug 14 '14 at 15:40
  • Tim, you are right. Delete ring worked much better in earlier versions. I use 2.8.1 Vienna, and are able to delete rings only if a zoom in and clicking the empty space within the ring. I played around with snapping options and tolerance, without any effect. Hope it'll be fixed soon. – nunatak Nov 18 '15 at 14:07
3

I haven't used any features which require Snapping so this is not a difinitive answer but I hope it might lead you to some kind of solution:

Settings > Options... > Digitizing

Check that the Default snap mode is not off. You may need to add a value for the tolerance.

Digitizing options

Afterwards, you can access the options for snapping via Settings > Snapping Options...

Snapping options

This will give you a set of options from a new dock window which opens at the bottom of the main window shown in the following image (this is assuming the snapping options opened in a dock window box is checked from the Digitizing options shown in the first image)

Snapping options window

Play around again with the values/options and hope that something works!

| improve this answer | |
  • 1
    I just tried this, but it's still messed up. – Tim Brown Aug 14 '14 at 15:02
  • 1
    Ring tool still seems to be broken in in QGIS 3.2.1 – maskin Jul 27 '18 at 14:45
  • @maskin - You should submit a bug report :) – Joseph Jul 31 '18 at 10:13
  • 1
    @Joseph True, I need to make some time to do that, and setup the accounts. :-) – maskin Aug 24 '18 at 16:00
  • 1
    @Joseph Bug raised, issues.qgis.org/issues/19784 – maskin Sep 6 '18 at 9:56
2

Snap tolerance is saved in the project file. So it may help to create a new project file, adding all layers one by one.

Or investigate the .qgs file with a good text editor (like notepad++).

| improve this answer | |
2

In my QGIS 2.4.0, the "delete ring" doesn't work when I have "on the fly" CRS transformation turned on.

| improve this answer | |
1

You might test the idea that you have non-compliant data in your layer. Create a new layer by making a very small buffer (0.0001 m for instance) and then carry out the operation on that. There are also tools in the vector menu to test for errors in the data.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.