1

I have used the latest addition to Mapnik PGRaster plugin (https://github.com/mapnik/mapnik/tree/2.3.x) by Strk(https://github.com/strk/mapnik/tree/2.3.x-pgraster) and merged recently.

I am able to get the images properly projected on the Map. But the images are tiled into an 8x8 manner and I could see the boundaries of the images at certain zoom levels.

enter image description here

I have added a Raster with a black patch so that the tiling boundaries would be more clear.

I am using OSM, Mapnik(2.3.x branch), ModTile and Renderd.

Also, when I run Renderd, I am getting logs like:

renderd[15011]: Rendering projected coordinates 14 4896 6056 -> -8061966.247298|5205055.878110 -8042398.368057|5224623.757351 to a 8 x 8 tile

I have added a layer via layer-shapefile xml as follows:

<Layer name="MS-GIS" status="on" srs="+proj=utm +zone=18 +datum=WGS84 +units=m +no_defs">
    <StyleName>raster</StyleName>
    <Datasource>
      <Parameter name="type">pgraster</Parameter>
      <Parameter name="table">ms_test</Parameter>
      <Parameter name="raster_field">rast</Parameter>
      <Parameter name="dbname">gis</Parameter>
      <Parameter name="estimate_extent">false</Parameter>
      <Parameter name="extent">-20037508,-19929239,20037508,19929239</Parameter>
    </Datasource>
</Layer>

How can I get the tiling to be smooth without boundaries?

  • I have seen the same effect, but only when doing a reprojection within Mapnik. If the source and destination are the same projection, the effect disappears. Another clue. – Paul Ramsey Jul 7 '15 at 20:37