3

I have QGIS 2.4 installed on a machine running Windows 7 64-bit "by accident". I was using 2.2 and when I added some package(s) it also installed the 2.4 version.

Can anyone provide some advice with the following?

  1. Remove version 2.4 and ensure there are no hooks, etc remaining on my computer (e.g. best method such as using Revo uninstaller or other)

  2. Re-install version 2.2 (I'm assuming it would be download it from here: http://qgis.org/downloads/ , specifically the file QGIS-OSGeo4W-2.2.0-1-Setup-x86_64.exe, dated February 26, 2014)

  3. Ensure that adding packages in the future doesn't automatically upgrade my version 2.2 to 2.X.

  • 3
    The easiest way I've found to install and keep QGIS up to date (or not, as you want) on Windows is by using the OSGEO4W installer (trac.osgeo.org/osgeo4w). You can use it to revert from 2.4 to 2.2. I don't know whether it would work in your situation, because (I'm guessing) you didn't use to set up QGIS to start with. But once you've fully removed 2.4, I would use the OSGEO4W installer to install 2.2. – Dan C Aug 19 '14 at 20:14
  • @DanC Would you have time to add your comment as a possible answer? – SaultDon Aug 19 '14 at 21:15
  • I'd rather wait and see if someone tackles the uninstallation part of the question, I've had that problem myself uninstalling QGIS (before I discovered the OSGEO4W installer). – Dan C Aug 19 '14 at 21:20
  • Maybe slightly off-topic. Could you give a short feedback about why you want to revert to the old version? If there are particular issues that you are experiencing it will help to improve the software if you leave a note about it. – Matthias Kuhn Aug 20 '14 at 10:49
  • I want to revert from version 2.4 to 2.2 because 2,4 broke some plugins I was using. – logrady Aug 20 '14 at 15:42
1

From the problem description you gave I assume you used the OSGEO4W setup installer, which installs everything inside C:\OSGEO4W.

You can safely remove that folder, or install QGIS 2.2 standalone from the source you mentioned in parallel. That will go into C:\Program files\, and it will never be updated until you remove it manually.

Plugins are stored in C:\users\<your username>\.qgis2. You can remove that too, but it should not harm unless you have installed plugins that will not work with QGIS 2.2.

The installer also makes some entries into the registry, but I would not advise to remove them unless you experience trouble.

  • I downloaded the installer file osgeo4w-setup.exe. When I used it months later v. 2.2 was instead installed. I tried to open a .SID file. It wouldn't work so I found out I needed to update GDAL (or something to that effect). I was not able to do this task with my current installer. I think I changed the installer to osgeo4w-setup-x86_64.exe. It may have been this that caused it upgrade from 2.2 to 2.4. I’ve now used two installers and both have changed the version. This is why I would like to know the exact file I need to maintain 2.2 and still allow package upgrades. – logrady Aug 20 '14 at 17:25
  • In the OSGEO4W setup, you can switch to Advanced install. There you can select the package you need, but you have to take an eye on the packages you don't want to upgrade: in the first column, you can toggle between the newst version, number, the one before and keep to leave your installation unchanged. the QGIS-OSGEO4W-setup works differently: it installs all packages in that file, and no upgrades. But you can not update GDAL only if it is too old or misses some drivers. The OSGEO4W-x86_64.exe should install into C:\OSGEO4W64, leaving the 32bit version in C:\OSGEO4W\ untouched. – AndreJ Aug 20 '14 at 18:29
  • I have another issue. QGIS is installed in the directory C:\OSGEO4W64. There is no C:\OSGEO4W\ directory. – logrady Aug 20 '14 at 18:39
  • That is correct for the osgeo4w-setup_x86_64.exe. The osgeo4w-setup.exe uses C:\OSGEO4W\, unless you change the default target. – AndreJ Aug 20 '14 at 18:57
  • I changed the default target to get it to work. Otherwise I was not getting the advance install option (or some other element) that allowed me to proceed. I accepted the defaults and obviously didn't pay close enough attention to what package(s) were being changed. BTW, I should add I was able to open the .SID file if that info is of any use to others with that problem. I will follow the above suggestions about reverting and confirm so we can close the question. – logrady Aug 20 '14 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.