1

I currently have a map where my map div covers 60% of the page and 40% is a fixed Infowindow. My problem happens with cartodb css and its z-index of div.cartodb-infowindow. Currently my information will not show in the fix div, however the html elements are there when I click on a point and if I manually go into the debugger and un-check the cartodb-infowindow, the information will show up.

So in my styles sheet I added .cartodb-infowindow and tried setting the z-index to a higher number than my side panel but no luck. I have tried a lower number and even setting the z-index to none. However I cannot override the cartodb css on z-index. (I have also tried using !important as well).

closed as off-topic by PolyGeo Dec 22 '18 at 20:34

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    for what I understand the info is displayed under the info-window because the z-index is lower. Use firebug to know what css class affects the info-window and what z-index value is used. Then define a z-index a little higher to the information class – Below the Radar Aug 21 '14 at 13:10
  • 1
    if not working use the !important tag beside the z-index css property to overide any other property that can affect the element – Below the Radar Aug 21 '14 at 13:11
  • 1
    I am using firebug to track down where the index problem exist and as stated above I had already tried using !important. After a hour I ended up downloading cartodb.css from github instead of linking the css and manually changing the z-index to :initial and that worked for me. – CrazySpatial Aug 22 '14 at 12:24
  • 1
    good to hear that. I have encounter that kind of situation before, and came to the same conclusion. It's better to have your own version of the css than linking to it. – Below the Radar Aug 22 '14 at 12:39
  • 1
    Could you mark the question as answered if this was solved in the comments? :) – iriberri Jul 30 '15 at 7:26

Browse other questions tagged or ask your own question.