1

I work on windows7. While installing GeoServer, I selected the 'install as a service' option. As I know when I installed GeoServer as a service, geoserver is already running. But I nagative to Web Administration Interface by url:

localhost:8089/geoserver/web/

I can't log in by username and password. It have an announcement "Invalid username/password combination". Do anyone know this problem and fix it. Help me, please!

  • 3
    Have you followed this documentation? Are you sure you have access to the security folder? – MickyInTheSky Aug 21 '14 at 8:39
  • 3
    Which GeoServer version? Which java version? When you run the installer were you logged in as admin? Did you install into "Program Files" or into some other directory? I recommend to install GeoServer 2.6-RC1 from geoserver.org/release/dev because it has some improvements in the Windows installer. – user30184 Aug 21 '14 at 8:44
  • I run manuallly geoserver before. This is the fist time I run geoserver as a service. I set Full control security to install folder but I still can not log in. what I have to do? – LL2 Aug 21 '14 at 8:51
  • 1
    You should not need to do anything more. If you do, the installer does not work as it should. If you find why it fails you can make a bug report for Geoserver and installer will be fixed. My questions try to help you to find why it does not work for you. Did you let the installer to create a new data_dir or did you use an existing one? – user30184 Aug 21 '14 at 8:56
  • I use the stable set up <i>geoserver-2.5.2.exe</i>, and jre7. I don't know <i>When you run the installer were you logged in as admin?</i> what is mean. I do not set username as admin, and password as geoserver. I set username and password by my name. I install in "Progame Files". – LL2 Aug 21 '14 at 9:06
1

For the GeoServer version 2.6-RC1 some work was done for making the Windows installer to work on Windows 7. The old installer version which worked well on Windows XP could not raise user rights of the GeoServer installation directory and data_dir on Windows 7 if directories were placed into "Program Files" or "Program Files (x86)". Installation into other directories like C:\geoserver was successful.

It is not sure if that was the reason why user @LL2 could not login to the GeoServer admin utility but anyway, installing GS 2.6-RC1 solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.