0

I am having a similar problem to Displaying ArcScene polygon extrusion edges?

When I extrude polygons in ArcScene 10.2.1, the polygons rise to the specified height, but the outlines of each feature are not displayed (Mapping Problem- top image). In particular, I'd like to see the outlines for each country, regardless of their extrusion height.

I've tried the suggestions listed in the aforementioned post, but do not get the desired effect. I even tried the user's solution to use the Feature to 3D by Attribute tool on the polygon layer. I then added that output layer to Arcscene without any extrusion, symbolized with no fill and a black outline, but again fail (Mapping Problem- bottom image).

I'm very new to ArcScene (but well-versed in ArcMap).

1

Create a matching polyline layer with an elevation field and populate with values that match the extrusion height. Display the polyline layer with the base height set to "Use a constant elevation offset in scene units" and choose the elevation height field you created that matches the extrusion height of the polygon layer.

This approach will outline the polygons at the correct extrusion height but will not colour the sides of the extruded features. If you extrude both the polygons and the polylines you will probably get rendering errors along the extruded sides since the 2 surface will "compete".

You could try this: use both the polyline and the polygon layer:

  1. extrude the polyline layer to build the sides
  2. set base height to the polygon layer (do not extrude) to match the line extrusions (think of it as lids to cap the hollow extrusions)
  3. add the same line layer again but set it's base height (do not extrude) same as the polygon layer. (this will outline the edges at the correct heights)
  • 1
    Thanks! Using a matching polyline layer did the trick. As you had suggested, I created and added a matching polyline layer and set the base height of this new layer to match the polygon extrusion values using the "use a constant value or expression" option. – Julie P Aug 25 '14 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.