3

I want to use postgresql9.3-postgis2.1 and gdal-bin parallel .

I have refer instruction here for installing postgresql-9.3 on ubuntu 12.04. I have install qgis from here

While installing gdal-bin it will remove postgis. As I explore I found similar question which says ubuntugis-unstable repository and postgresql repository will not work together.

enter image description here

Then how can install postgresql9.3-postgis2.1 and gdal-bin parallel. Can someone help to solve the problem , Any suggestion will be great help for me.

Thanks

  • ubuntugis-unstable has packages for postgresql 9.1, gdal 1.10 and qgis 2.4. Is there any reason you need postgresql 9.3? – AndreJ Aug 24 '14 at 5:04
  • Hi Andre, I want use json_parse . which is not available in 9.1. Thanks – Amit Aug 25 '14 at 6:26
  • PostgreSQL 9.3 is available via ubuntugis for Ubuntu 14.04, but the geos package is still missing for that platform. So self-compiling seems to be the only option. – AndreJ Aug 25 '14 at 7:27
1

I have installed postgis by configure using source.

Download the latest PostGIS source and compile it

wget http://download.osgeo.org/postgis/source/postgis-2.1.0.tar.gz
tar xzvf postgis-2.1.0.tar.gz 
cd postgis-2.1.0
./configure

make
checkinstall

For more details visit , Thanks

  • That's not the latest. The latest is postgis-2.1.3. Latest stables are listed here: postgis.net/source – LR1234567 Aug 24 '14 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.