1

I am developing an application using map services served by ArcGIS Server 9.3. The application must be completely https since it is shared through a secure Intranet. The application itself, all of the javascript libraries, and all of the map services I call are https. The browser I have to use is IE 11 and I am not able to upgrade to Server 10.

The map services do not load because I receive the network error that: http://utility.arcgis.com/sharing/tools/legend?soapUrl=..... is not SSL enabled

I've previously read the following,

"If the layers are version 10 or lower the legend is created using the ArcGIS.com legend service. In order to use the ArcGIS.com legend service your map service needs to be publicly accessible and your application must be able to access ArcGIS.com."

Is there any way around this? Also note - I do not actually need a legend - so even if there is a way to disable the legend service to be called, that would work!!

1

I ran into a similar issue. The only way I could really see (although not exactly security safe) is to disable only secure content through HTTPS sites. This MSDN Help tells how to change your security settings.

Note

I only got this to partially work last time I tried it. I was trying it through Google Chrome though. If this is for internal use, you might be able to set a custom security setting to allow this to work.

Another method I was trying to figure out was adjusting the API's legend service call through ESRI's API files (assuming you downloaded them to your web server and are not calling the one's on ESRI's site). I looked, but I didn't find the URL for the service call to see if I could adjust that to HTTPS and have it work. I don't even know if this is a viable option or not though.

Best of luck...

  • Thanks for the comment - I unfortunately am not able to change the security settings. Does anyone know where we can change the API files to make the legend service run via https?? – Sara Flecher Aug 25 '14 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.