4

I just spent the last n hours working on this, and still haven't gotten anywhere, so I'll throw it to the group. I see that other people have asked about this here and here, and I'd be happy to take down this Q if that gets answered.

My specs:

  • Mac 10.9.4
  • Mavericks OS

I'm trying to install QGIS. I'm working with the KyngChaos package. It gives me an error on installation, saying, "Failure: The GDAL 1.11 framework is required." I've since tried to brew install gdal, which installed the 1.10 framework. QGIS installation still fails. I then did brew update, and tried again (which seemed promising). Still fails. I then tried to follow this guy's approach, and brew install qgis. This kept my Terminal busy for about 3-4 hours... and still failed. Though I swear I saw a green-fonted gdal library get installed in all that Terminal chatter.

FWIW, the brew install qgis gave me a slightly different error message:

[ 50%] Built target qgis_gui
make: *** [all] Error 2

No idea what this means. I'm trying to find gdal in my computer via the Terminal: mostly doing which gdal -a, though this doesn't return anything. So I'm not sure how to even check that GDAL 1.11 got installed.

  • I have no experience with MAC, but Kyngchaos offers a GDAL complete 1.11 package, which requires Apple's Java 6. I suggest to start with the latter, then the GDAL package (and Matplotlib), then QGIS. If it still fails, look out for an installation log. – AndreJ Aug 26 '14 at 14:51
  • try "gdalinfo --version" to know the installed version – radouxju Aug 26 '14 at 14:51
5

For QGIS on Mac, the Kyngchaos.com installer package is built against the GDAL_Complete installer framework from the same site, as is noted under Requirements on the download page. It will not work with gdal from the Homebrew project.

If you want to go with a purely Homebrew approach, try the OSGeo4Mac project. First run brew unlink qgis, which is the outdated formula version in homebrew/science, then do run the following:

brew install osgeo/osgeo4mac/qgis-24

If you are on Mavericks and you're using the default HOMEBREW_PREFIX of /usr/local, qgis-24 and several of its default dependencies will be installed via 'bottles,' i.e. pre-built binaries, instead of compiling from source code, saving you a huge amount of time. If you change the default build options for qgis-24 to something else, then it will build from source again.

If you have any issues, please post them to the OSGeo4Mac tracker, instead of here.

  • Thanks! I was getting "No available formula with the name "osgeo/osgeo4mac/qgis-24" " then I realised that the OSGeo4Mac project was already in qgis-28 so I used that version instead. – pcambra Nov 6 '15 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.