3

I installed GeoServer 2.5.2, GeoNetwork 2.10.3 and Tomcat 7 on my Windows 7 computer {MyComputer} in our company's network. Now I would like to access GeoServer, GeoNetwork and Tomcat from other computers in the network.

However, I could only access via the web browser GeoNetwork and Tomcat but not GeoServer.

NO - http://{MyComputer}.{domain}.com:8070/geoserver/web/

YES - http://{MyComputer}.{domain}.com:8040/geonetwork/srv/eng/main.home

YES - http://{MyComputer}.{domain}.com:8080

Is there any configuration that I missed?

2
  • 1
    DO you have a firewall, or something else that might block something on the 8070 port? secondly, when you say you cannot access, what exactly do you see? do you see a timeout error or something else? Aug 27, 2014 at 3:26
  • Yes I have a firewall enabled. How do I set port 8070 opened? What I saw on the browser is "This webpage is not available" on Google Chrome.
    – alextc
    Aug 27, 2014 at 3:31

2 Answers 2

4

Problem solved. I had to add a New Rule to the Advanced Firewall Settings for opening port 8070 for inbound traffic.

1
  • 1
    It's great that you shared how you solved this problem. Aug 27, 2014 at 3:37
0

Make sure on which port your geoserver is running, then to open the firewall in linux use these 2 commands from root:

  1. for e.g. if your port is 6789 on which your geoserver is running then use:
firewall-cmd --zone=public --add-port=6789/tcp –permanent
  1. Reload the firewall
firewall-cmd --reload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.