5

I am working in QGIS 2.4. I have changed the CRS of all the layers and in the project properties to EPSG:102739 - NAD_1983_StatePlane_Texas_Central_FIPS_4203_Feet.

I am in print composer trying to create a scale bar and I can not figure out why the scale is so off. I am trying to go from feet to miles and it just creates a really long scale bar. Basically 1 mi = 5280 is what I am going for I have already checked each layer and they are all in state plane 4203. I am not sure what I am missing. I checked other threads about scale in QGIS and I am still at a loss. I have tried flipping the conversion around and its still not working.

Edit 2: Sounds crazy is there a difference between Qgis for Windows and for Linux. I loaded the exact same data(just copied and pasted the file with the map and data) to a windows computer. Opened it and everything works fine.

Edit: The answer given How to get correct scale values? does not address my issues. I have already done everything in that answer. All of my layers have been resaved with projection and the project projection has been changed.

Using scale bar units in QGIS composer?

What do I need to change to get scale bar units other than degrees?

Why does QGIS scalebar show a wrong scale? enter image description here

enter image description here

enter image description here

3

Judging from the coordinates we can see on your second screenshot (-99,30), I think that you changed the layer CRS in layer properties instead of properly reprojecting the data to state plane. Reproject the layers and try adding the scale bar then.

  • Hello, I have already done that. I choose my layer did a save as and changed the CRS that way, but it is still not working – T.J. Aug 28 '14 at 13:14
  • 2
    If the extent of your layers is in degrees, you will never get feet as units. It looks like you have broken the shapefiles with false assigning of CRS. – AndreJ Aug 28 '14 at 14:51
  • 2
    With EPSG:102739, the extent of your data should be xMin,yMin 2694660.40;9820568.01 : xMax,yMax 3315333.67;10415697.74 – AndreJ Aug 28 '14 at 15:01
  • Thanks!! I just changed everything to NAD 83 which works. – T.J. Aug 28 '14 at 23:47
0

Try opening your .prj files in a text editor (Notepad, Notepad++, etc.) and then check out the text there. If the CRS saved correctly it should say: PROJCS["NAD_1983_StatePlane_Texas_Central_FIPS_4203_Feet", GEOGCS["GCS_North_American_1983", DATUM["North_American_Datum_1983", SPHEROID["GRS_1980",6378137,298.257222101]], PRIMEM["Greenwich",0], UNIT["Degree",0.017453292519943295]], PROJECTION["Lambert_Conformal_Conic_2SP"], PARAMETER["False_Easting",2296583.333333333], PARAMETER["False_Northing",9842499.999999998], PARAMETER["Central_Meridian",-100.3333333333333], PARAMETER["Standard_Parallel_1",30.11666666666667], PARAMETER["Standard_Parallel_2",31.88333333333333], PARAMETER["Latitude_Of_Origin",29.66666666666667], UNIT["Foot_US",0.30480060960121924], AUTHORITY["EPSG","102739"]]

If it doesn't match that then just replace your current .prj with this text. That will set your projection correctly and then your units will be in feet.

  • 1
    Overwriting the .prj file is not generally good advice without knowing exactly what was done to the data before. – underdark Aug 28 '14 at 16:44
  • 1
    ... and it does not reproject any coordinates from one CRS to another. – AndreJ Aug 28 '14 at 18:38
  • He could still check to see if the .prj file is matching what it should be to see if QGIS is reprojecting correctly. – cbunn Sep 2 '14 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.