2

I have been unable to run R from within QGIS on my computer. I have R version 3.03 installed and QGIS 2.4 on Windows 7. R is located at C:\Program Files\R\R-3.0.3\bin\and this is the path e specified in Processing Options -> Providers -> R Scripts -> R Folder in QGIS.

The error message I receive is

Missing dependency.This algorithm cannot be run :-( 
This algorithm requires R to be run.Unfortunately, it seems that R is not installed
in your system, or it is not correctly configured to be used from QGIS 
Click here to know more about how to install and configure R to be used with QGIS

I have tried changing the R folder to other R executables, but nothing works.

  • Have you tried setting the path to R contained within QGIS? Here is an example of my path for the R Script folder: C:\Program Files\QGIS Valmiera\apps\qgis\python\plugins\processing\r – Joseph Oct 6 '14 at 15:39
  • The path maps to my currently installed version of R. When I install QGIS, it does not appear to install R and I am not sure why. I would like to have an R version embedded in QGIS, but it does not give me this option. – user44796 Oct 14 '14 at 19:36
  • Should not "R folder" be the R install directory, and not the bin directory. For example C:\Program Files\R\R-3.0.1, as suggested in gis.stackexchange.com/questions/63922/… – Håvard Tveite Apr 27 '15 at 12:32
3

The issue is that R is installed under Program Files by default, which is write-protected. Install R into another folder such as C:\R\R-3.1.3 and the problem goes away when you set it as the R path in QGIS. The solution is described here: http://wiki.awf.forst.uni-goettingen.de/wiki/index.php/R_installation

This worked running QGIS 2.8.1 Wien on Windows 7 64-bit.

  • Thanks a lot for this tip. Actually I placed the bin folder in R folder (C:\R\R-3.3.0\bin) and I continued to get the Missing Dependency dialog. Once I modified to C:\R\R-3.3.0, everything just worked like magic! – user74118 May 29 '16 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.