2

In QGIS, when I insert a kml contour that was created in Google Earth, it appears misaligned in respect to all the other layers.

Note in this image how the red contour is moved upwards with respect to where it should be (use the house and the road going south as reference).

I am using EPSG:3003 as project CRS, all the different layers I have in my project from WMS services overlay correctly. The kml layer is set to EPSG:4326 (WGS 84) and I have set "automatic on the fly reprojection" in the options of QGIS. The CRS of the raster is set to EPSG:3003.

I have QGIS 2.0.1 but the same problem happens in 2.4.

example screenshot

  • The raster image is it in 3003? – Sergio Sep 1 '14 at 11:41
2

If you use the Openlayers plugin inside QGIS, you have to set the project CRS to EPSG:3857, not EPSG:3003. 3003 is for Italy only, but the Openlayers plugin is worldwide.

The other layers may still have other CRS.

1

SOLVED:

I was convinced that the raster was in EPSG:3003, but actually it was not! The raster layer was coming in as EPSG:4326 from the map server, even though I had set it to 3003 in the layer property (see screenshot). This is where the problem came from and all my other layers had the same problem. So I have now specified a new layer source, being sure that it starts with crs=EPSG:3003.

image

  • I think that you could solve the problem with the "reprojection on fly" option. That dataset is served also in EPSG 3003 – MickyInTheSky Sep 1 '14 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.