3

when trying to import a CSV from my hardtrive to my map-document using "add Data"-dialog I get the error "Selected element could not be added to map. Generic error" (or something similar, I am using german version, so actual message may vary). When doing the same via TableToTable_conversion-tool in GP I get the error 000732: Dataset 'myFile.csv' not existing or not supported. I also tried to create a file-GDB and import the table there, result is the same.

Here is my CSV-structure:

SID,UUID
1,DENW22AL60001dVy
1,DENW22AL30000FLl

I also tried with semicolons rather then single comma as delimiter, but can´t get it working. Also notice that I only want a standalone-table rather then a featureclass. Therefor no coords are given within the file.

EDIT: As of Error: 000732: Dataset does not exist or is not supported this error may occur if the file-name itself is incorrect. So I did the proposed corrections for filenames (use forward-slashes, no spaces) but with no avail. Also since I chosed the file by the file-dialog rather then by typing its name I did not even expect this would do the trick (just for completeness).

I´m using ArcGIS 10.0 for Windows 7 (64Bit)

2

By default ArcGIS reads csv files as comma delimited, but sometimes it's not the case, probably due to local language settings. You can force the way ArcGIS reads your csv file using the schema.ini file. Normally, there is a schema.ini file in the same location as your csv file, and its content should look like this if you open it in Notepad:

[myFile.csv]
Format=Delimited(,)

It you don't find the schema.ini file or if its content is different, create it (create a text file named schema and change its extension) or modify it so that its content is the same as the example above.

More info about how ArcGIS handles ascii files here: Adding an ASCII or text file table.

  • 1
    I tried both: using Delimited(,) and CSVDelimited as proposed by your link, but none of them worked. I also supposed that it might be that error, that was why I also tried another file with semicolons (to indicate if its the same error). But also to no avail – HimBromBeere Sep 3 '14 at 7:27
  • 1
    You can confirm which SP are installed by clicking Help > About ArcMap in ArcMap. If not done yet, please install SP5, version 10.0 without SP is full of bugs. German SP5 here, English SP5 here. Or migrate to 10.1 or 10.2.2 if you can. – GISGe Sep 3 '14 at 7:48
  • 1
    OK, after having updated to SP5 I run into the same error... Btw.: I cannot upgrade to 10.1 or later due to restrictions of my company – HimBromBeere Sep 3 '14 at 9:01
  • Could you send your data then? – GISGe Sep 3 '14 at 9:02
  • 1
    ArcGIS 10.0 is in Mature support status, so generating a bug report for something that works at the current release will be of dubious value. Still, Tech Support may be able to help you find a work-around. – Vince Sep 3 '14 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.