5

My problem is as follows:

I imported a number of shapefiles from a .gpx-file from a gps-device. Each shapefile contains a number of waypoints. For the study I am doing, I need to give all of them unique ID's. I simply selected each shapefile, toggled the editing-switch and changed the name in the attribute table's name-column. Though for some reason, I cannot toggle editing of two of the 20 shapefiles. All of them have the same coordinate system as the project, so I don't understand why I cannot find the solution.

I am still in the rookie-phase of using GIS, so I might have overlooked some obvious solution. I hope someone here can help me.

4

If you import from gpx, the layers are still bound to the gpx file. These are very restricted in editing capabilities, because gpx does not allow all that you can do with shapefiles.

You have to save the layer to "ESRI Shapefile" format, add that to the canvas, and delete the gpx layer from canvas.

Adiitionally, some shapefiles can not be edited if you have set a filter on the data.

By the way, current version of QGIS is 2.4. Some features have improved a lot since 1.8

  • Hi there, thanks for the quick reply! I am using qgis 1.8 since I used it before and expected to be more familiar with the use of it, also I figured more extensions/ plugins would be available since it is an older version? Might have been a bold assumption, just sounded reasonable to me. With regard to the question I posted; I allready saved the layers as esri shapefiles, and the typical issue was that out of 20+ layers, 2 couldn't be edited. The original gpx files were deleted. I think there was no filter on the data too. – Teun88 Sep 9 '14 at 18:38
0

From the OP's question and ensuing comment, the data is already in shapefile format with no filters applied; of a total of 20, only 2 are non-editable.

One further possible reason is that QGIS will disable the 'edit toggle' if the source shapefile is located in a directory to which write-access is denied. In this case either modify the security settings on the folder+data, or move the shapefiles to a more appropriate location.

Source: just tested in QGIS 2.16.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.