4

We're in the middle of a migrating process.

We've imported a geodatabase on a new Linux machine and we're trying to publish some map services to this new ArcGIS Server (that resides on the same machine).

We've upgraded the 10.1 geodatabase to a 10.2 one.

The geodatabase was imported via pgAdmin backup- restore procedure then we used the Upgrade Geodatabase tool from ArcToolbox to go to 10.2.

We've encountered problems when trying to register the geodatabase with the server. The error we get is:

The connection property set was missing a required property or the property value was unrecognized. This release of the GeoDatabase is either invalid or out of date. DBMS table not found

enter image description here

Same error occurs with a new created geodatabase as well.

Details:

  • ArcGIS Server 10.2 on a Linux Machine
  • PostgreSQL Geodatabase 9.2 on the same Linux Machine
  • 1
    Are you upgrading to 10.2 or 10.2.2? The reason I ask is I tried upgrading to 10.2 once and had so many issues I went back to 10.1. When 10.2.2 came out I tried again and had success. – brenth Sep 5 '14 at 14:57
  • The geodatabase we imported was a 10.1 and we've upgraded it to 10.2 with an ArcGIS Desktop 10.2.2 Could this be an issue? The ArcGIS Server is a 10.2. We tried to install the 10.2.2 version and we encountered problems at the authorization process so we came back to 10.2. – Ligia Sep 8 '14 at 6:53
2

You probably need to change the pg_hba.conf file to enable for remote connections.
Then you need to register the db with ArcGIS server.
In ArcGIS server you will go to the Site tab, and choose datastore.
Copy your sde connection file to the sever
and point to that connection file.
enter image description here
enter image description here

  • We've tried this method as well, but at the Import stage after we selected the connection file, the process remains stuck on loading, and at the developer's tools console there is 500 server error. – Ligia Sep 8 '14 at 6:58
  • We've changed the pg_hba.conf file to enable for remote connections. Still no. – Ligia Sep 9 '14 at 13:39
  • @Ligia can you register a new geodatabase (10.2) with this method, or does importing the sde connection always cause 500 server error? – Tom Sep 9 '14 at 14:59
  • Hello Tom. We've tried registering a new geodatabase and we got the same error as well. – Ligia Sep 9 '14 at 15:07
  • We've talked to ESRI meanwhile, gave them access to our server and apparently something's wrong with ArcGIS Server's Publishing Tools.They didn't say what exactly. So 10.2 on a Linux may not be a good option. – Ligia Oct 15 '14 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.