0

I'm using QGIS on Mac (most recent version) and am trying to map coordinates from a csv file. When I import the file normally without having any base map, the coordinates how up distributed like I want. When I put a base map like Google Street View and then add the coordinates, the coordinates don't show up anywhere. Instead, I get a dot in the middle of the map (off the coast of Africa). What's the reason for this? I was told to use Pseudo Mercator EPSG:3857 WGS 84. I've tried using different projections as well.

I am using longitude/latitude coordinates. For either OpenStreetView or Google Street View, the same issue is happening.

  • Are the CSV file coordinates in latitude/longitude, or something else (UTM, feet, etc)? – Erica Sep 6 '14 at 20:44
  • 1
    Would you be able to edit your question to clarify whether you are using OpenStreetView or Google's StreetView, please? Your title seems to contradict your question. – PolyGeo Sep 6 '14 at 22:53
1

I assume you are not using OpenStreetView or GoogleStreetView inside QGIS, but the Openstreetmap layer and Google satellite layer provided by the openlayers plugin.

For that, project CRS must be in EPSG:3857.

If you have coordinates in lat/long, you have to add a layer with layer CRS set to EPSG:4326, and "On-the-Fly-Reprojection" enabled. Then the coordinates get automatically reprojected to the right place in EPSG:3857.

It might be helpful to go to Settings -> Options -> CRS, and set Prompt for CRS for new layers. Otherwise your csv table might be assigned to the project CRS without further notice, which is definitely wrong for lat/long coordinates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.