4

I had the georeferencer window open in QGIS 2.4 while project was running, I accidentally closed the Qgs document with the georeferencing window open (worked absolutely fine till then). When I opened QGIS again and clicked the georeferencing plugin, the window doesn't open.

I tried closing and opening the Qgs doc, deleting temp files, opening QGIS 2.2, restarting computer, but the problem persists. I don't see any error logs in QGIS when I try to open the window.

Any help or possible error checklist is welcomed.

Update I've tried a quick re-install of QGIS 2.4, still no luck. looks like a complete purge is needed.

Update 2 I created a new user on my computer, it already has QGIS installed, and the georeferencer plugin works fine.

  • Do you have both QGIS 2.2 and 2.4 installed? Do you use windows? Using QGIS 2.4 and OpenSUSE 13.1 I cant reproduce described issue. – SS_Rebelious Sep 7 '14 at 12:07
  • Yes, 2.2 and 2.4, Windows 7 Pro. – HDunn Sep 7 '14 at 12:10
  • Did you try to delete your QGIS user directory? If there is no specific reason for using both vesions, I would suggest to uninstall 2.2 and reinstall 2.4. – SS_Rebelious Sep 7 '14 at 12:15
  • When I installed 2.4, I noticed several features didn't work as well as 2.2, so I kept it. Like I said, there was no issue with the georeferencer, it worked perfectly in both versions even when both were active – HDunn Sep 7 '14 at 12:22
13

I had the same problem. This should solve the bug (QGIS 2.6 under Windows):

  • close QGIS
  • using regedit.exe, search for "Plugin-GeoReferencer". This should point to a folder under \HKEY_CURRENT_USER\Software\QGIS\QGIS2\Plugins
  • (optional: export a .reg version of the folder for back-up)
  • delete the folder "Plugin-Georeferencer"
  • restart QGIS. Georeferencer window should now open
  • I had the same problem, solved with the Regedit trick, answer n. 3! Thanks! Carlo – user34423 Dec 10 '14 at 9:21
  • Please do not use the area reserved for direct answers to the question to make comments. The way to say thanks here is to upvote. – PolyGeo Dec 10 '14 at 9:27
0

If it's in docked mode it might just be hidden

enter image description here

  • It's not docked nor hidden. The only thing that seems to happen is when I click the plugin, it cancels the active window (blue rectangle). Worth mentioning also clicking on the georeferncer button in the Raster toolbar doesn't work. – HDunn Sep 7 '14 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.