3

I am using q. 2.5 4291337 in Windows 7 64 bits. I am working with raster and vector layers in EPSG::26714 (UTM NAD27 14N). In this version of QGIS, you are able to put a grid in a different CRS of the layers in Print composer. I tried to play with this option but I have some odd results.

When I set that I want a lat-lon Nad27 grid (EPSG::4267) and set the coordinate format to decimal, everything is OK. Longitudes are shown as negative numbers and latitude are positive.

enter image description here

When I set to show the labels to deg min sec with suffix the label shows wrong the hemisphere indicator. The suffix for my longitudes are labelled as "S" and for my latitudes are labelled "E".

enter image description here

I tried to replicate the problem with a project with layers in EPSG::4326 (Lat lon WGS84), and I do not have such a problem.

enter image description here

How do I set correctly the options to use a grid in a different CRS than my layers in print composer?

In the project with UTM layers, I chose the CRS for my grid to EPSG::4267. I set the spacing as .01666666 for X and Y (which is equivalent to 1 minute).

Also I asked a friend of mine who uses Ubuntu and he does not have such a problem.

4

This was a bug in the development version of QGIS which coincidentally was fixed yesterday! See https://github.com/qgis/QGIS/commit/3af6dbc4e1fc49b4b755a542e9583573365a4bd2 . Download the next daily snapshot and you should be right.

  • I tested and it is working correctly, now everything shows ok! – Gerardo Jimenez Sep 9 '14 at 3:54
  • It even does change the hemisphere identifier (O or W) depending the language you are using. Having this option in composer is a great tool for final maps. – Gerardo Jimenez Sep 9 '14 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.