Has anyone ever encountered this message? I am getting this when I try to open certain shapefiles. I am working on a problem that generates shapefiles from spreadsheets using ThinkGeo's .NET tools. When I try to open ones where I have approximately 142 columns (of mostly string, some float, and a couple datetime fields) I get this message. I don't get anything else besides this message.

I can open the file in ArcPad 8.0 and QGIS 2.0.1, but it fails every time with ArcMap. I have run the shapefiles through Andrew Williamson's ShapeChecker, which found no problems. Going through the Check Geometry tool gives me an ERROR 000229 saying it cannot open the file. It doesn't have a lock on it, so there is something else happening.

Any tools or suggestions that I should look in to?


I am using ArcMap 10.2.2. I can view the files in ArcCatalog, but when I go to preview them, I get a message saying "Open Failed" as the title and "Error opening feature class". I tried loading this up in ArcCatalog 9.3.1 and ArcMap 9.3.1. I am able to see the shapes drawn out, but anytime I try to view the attribute data, it crashes without explanation.

This is point data generated from x/y coordinates that were generated from ArcMap originally.

What I don't fully understand about these errors is how to tell exactly what it is. I have up to 255 columns of data that I can include. I am able to include all the data if I break up the columns into smaller chunks. It seems like for whatever reason my 'no crash' limit is around 142 columns.

As for record count. ArcMap throws an ERROR 000229 Cannot Open when I try to run it on the shapefile. ShapeChecker verified that the row count and feature count match though.

I have also checked the field name length as I generate them. None go over 10 characters. I haven't found anything definitive yet as to what causes my errors or how to solve them.

  • Have you tried opening it in QGIS and then exporting it into a new shapefile, and opening that in ArcMap?
    – ianbroad
    Sep 9, 2014 at 18:27
  • I have tried that, and I got the same result.
    – Branco
    Sep 9, 2014 at 19:28
  • call me Captain Obvious, but did you check to be sure the basic 3 necessary files .shp, .dbf, .shx are all there? It seems like the other checks you have done probably rule that out. Sep 9, 2014 at 20:25
  • Can you make a copy of the shapefile in a different workspace and try again? Also, try viewing the shapefile in ArcCatalog.
    – evv_gis
    Sep 9, 2014 at 20:38
  • Can you edit your question to indicate whether you can see this shapefile in the Catalog window of ArcMap (and/or in ArcCatalog), and also to provide your ArcGIS for Desktop version, please?
    – PolyGeo
    Sep 9, 2014 at 21:42

2 Answers 2


I think the fact you can make 140 rows work, not make 150 rows work, have a 1-1 relationship in shapechecker, QGIS opens the data, and can view the shapes but not the attributes in ArcCatalog tells me you have an illegal attribute value in a row around 142. A invalid non-UTF 8 character. I am almost certain as the WDPA used to have the exact same issue. Post the file and I am sure we can find it.

Maybe a Latin Character or similar. Open in QGIS but this time save explicitly as UTF-8 in the drop down with a new name and try in ArcGIS, try to post the shapefile as well.

I can recreate this with illegal characters in the attribute table in text fields.

  • It has been a long time, but I think the data was all valid. I believe the problem mostly is with the ThinkGeo .NET tools I was using. Their software has since corrupted shapefiles in the simplest of ways. I don't have the project anymore or I would test and check again.
    – Branco
    Dec 23, 2015 at 13:33
  • On can you add this as an answer and accept it so we can clear it from the board. Dec 23, 2015 at 17:55

From an answer to another question How to programmatically check if the number of shapes = number of table records? I think you should try running the Get Count (Data Management) tool on your shapefile and be open to the possibility that your shapefile may have a different number of geometries (in *.shp) and attribute rows (in *.dbf).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.