When displaying raster files in Qgis with the color-ramp stretched to the min/max values of the current display extent, the min/max values don't update automatically when zooming or panning to a new area.

The only way i know around it is to manually recalculate the values each time, which can be quite a pain.

I know this functionality to be a basic feature in ArcMap, so maybe I'm just missing something in the display options. So if anyone knows how to get the min/max extent to auto-update, please let me know how to do it. Thanks!

BTW: I'm currently using Qgis 2.4.0, but I encountered the same issue in all earlier versions I worked with.

1 Answer 1


Yes what you say is correct, but a plugin called "Raster" can help you a little bit. But this works only on grey scale.Raster plugin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.