1

I've only been using GIS for a couple of months so this is probably just a really basic/novice problem but I cannot for the life of me fix it.

The other day I managed, with a lot of finagling, to create a map out of an Excel spreadsheet I had made with lat/long in DD and a generic basemap. For some reason the data was not lining up with the basemap and I can't remember how I got it to work in the end - mostly a lot of trial and error. Unfortunately I moved the Excel source so when I reopened it later it had the whole red exclamation mark deal next to the data. I re-set the source but now it's refusing to line up and I CANNOT fix it. I've tried everything I can think of, including starting completely over. The dataframe and Excel sheet layer have the same coordinate system and I added the basemap after defining the coordinate system for the dataframe. The data is showing up directly in the center of the Atlantic Ocean (it should spread from the west coast of US through Europe.)

Is there something obvious I'm missing?

  • Would you be able to edit your question to include the GIS software and version that you are using, please? – PolyGeo Sep 12 '14 at 21:00
  • If the data frame is using a projected coordinate system, the Excel data is almost certainly in lat/lon (decimal degrees) as you said. When you use the Add XY Data dialog, set the coordinate system to WGS84 or whatever it is, not the projected coordinate system. – mkennedy Sep 12 '14 at 21:48
  • @PolyGeo given the red exclamation point and problem with Excel data--it's probably ArcMap, don't you think? b-> – mkennedy Sep 12 '14 at 21:49
  • You're right @mkennedy - I'll tag it arcgis-desktop and coordinate-system – PolyGeo Sep 12 '14 at 23:26
0

1) Start a blank new ArcMAP

2) Add only the basemap and nothing else

3) File > Add Data > Add XY Data> Add the Excel

4) Lat is Y and Long is X (Do not hit complete or finish, or enter, or whatever)

5) You should have an option to set the projection here,. Set it to Geographic > World > WGS 1984.

6) Now finish bringing in the excel.

7) Now right click on the excel in the table of contents (usually has a $ Symbol).

8) Export Data (Data > export)

9) Save as a shapefile but check the box that sat something like "Map frame as the projection" or the one that does not say same as the layer. I forget the name.

10) Bring the shapefile into ArcmAP

11) Remove the Excel.

12) Save the MXD

| improve this answer | |
  • Thank you so much! Worked perfectly. I was using a different projection that I guess didn't line up with the basemap's projection. – user36952 Sep 13 '14 at 2:42
  • Thanks, if it worked could you mark it as the correct answer. It is how stack exchange works. You should have a checkmark or similar. – If you do not know- just GIS Sep 13 '14 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.