1

attention: This might be more a question for "askubuntu.stackexchange" but it is GIS-related Geonode 2.0 is available for Ubuntu 12.04 but not for Ubuntu 14.04. According to the docs it should be sufficient to make an

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:geonode/release
sudo apt-get update
sudo apt-get install geonode

I have a fresh install of Ubuntu Server 12.04 with a default LAMP configuration and it already fails on the first line:

Depends: python-pycurl but is not installable

The first line works on Ubuntu 14.04 but geonode will not be installable on 14.04. I am somewhere stucked. Is there a Geonode release available for 14.04?

2

It seems that a stable version of geonode 2.x branch is not still released for Ubuntu 14.04. The suggestion of the developers is install the testing 2.4 version from the ppa.

sudo add-apt-repository ppa:geonode/testing
sudo apt-get update
sudo apt-get install geonode

geonode createsuperuser
sudo geonode-updateip 127.0.0.1

You can also try to install it by hand as is shown in this post, where is installed in virtual machine of ubuntu 14.04 with vagrant.

| improve this answer | |
1

I confirm that ppa:geonode/testing works on Ubuntu 14.04; then you have to add at the end of the file /etc/geonode/local_settings.py (otherwise you'll have this error 403 forbidden DEBUG is set to False but the host of the path provided to the proxy service is not in the PROXY_ALLOWED_HOSTS setting) this line:

PROXY_ALLOWED_HOSTS = ('127.0.0.1',)

and then restart apache /etc/init.d/apache2 restart.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.